Gentoo: GLSA-202105-32: PostgreSQL: Multiple vulnerabilities | Linu...

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202105-32
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: PostgreSQL: Multiple vulnerabilities
      Date: May 26, 2021
      Bugs: #771942
        ID: 202105-32

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PostgreSQL, the worst of
which could result in information disclosure.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

     -------------------------------------------------------------------
      Package              /     Vulnerable     /            Unaffected
     -------------------------------------------------------------------
   1  dev-db/postgresql             < 13.2               >= 9.5.25:9.5
                                                         >= 9.6.21:9.6
                                                           >= 10.16:10
                                                           >= 11.11:11
                                                            >= 12.6:12
                                                            >= 13.2:13

Description
===========

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.

Impact
======

An authenticated remote attacker, by executing malicious crafted
queries, could possibly disclose sensitive information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL 9.5.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.25:9.5"

All PostgreSQL 9.6.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.6.21:9.6"

All PostgreSQL 10.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-10.16:10"

All PostgreSQL 11.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-11.11:11"

All PostgreSQL 12.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-12.6:12"

All PostgreSQL 13.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-13.2:13"

References
==========

[ 1 ] CVE-2021-20229
       https://nvd.nist.gov/vuln/detail/CVE-2021-20229
[ 2 ] CVE-2021-3393
       https://nvd.nist.gov/vuln/detail/CVE-2021-3393

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202105-32

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202105-32: PostgreSQL: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in PostgreSQL. Please review the CVE identifiers referenced below for details.

Resolution

All PostgreSQL 9.5.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.25:9.5"
All PostgreSQL 9.6.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.6.21:9.6"
All PostgreSQL 10.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/postgresql-10.16:10"
All PostgreSQL 11.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/postgresql-11.11:11"
All PostgreSQL 12.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/postgresql-12.6:12"
All PostgreSQL 13.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/postgresql-13.2:13"

References

[ 1 ] CVE-2021-20229 https://nvd.nist.gov/vuln/detail/CVE-2021-20229 [ 2 ] CVE-2021-3393 https://nvd.nist.gov/vuln/detail/CVE-2021-3393

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202105-32

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: PostgreSQL: Multiple vulnerabilities
Issued Date: May 26, 2021
Bugs: #771942
ID: 202105-32

Synopsis

Multiple vulnerabilities have been found in PostgreSQL, the worst of which could result in information disclosure.

Background

PostgreSQL is an open source object-relational database management system.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-db/postgresql < 13.2 >= 9.5.25:9.5 >= 9.6.21:9.6 >= 10.16:10 >= 11.11:11 >= 12.6:12 >= 13.2:13

Impact

An authenticated remote attacker, by executing malicious crafted queries, could possibly disclose sensitive information.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.