Gentoo: GLSA-202105-38: nginx: Remote code execution | LinuxSecurit...

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202105-38
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: nginx: Remote code execution
      Date: May 26, 2021
      Bugs: #792087
        ID: 202105-38

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in nginx could lead to remote code execution.

Background
==========

nginx is a robust, small, and high performance HTTP and reverse proxy
server.

Affected packages
=================

     -------------------------------------------------------------------
      Package              /     Vulnerable     /            Unaffected
     -------------------------------------------------------------------
   1  www-servers/nginx            < 1.21.0                >= 1.20.1:0
                                                    >= 1.21.0:mainline

Description
===========

It was discovered that nginx did not properly handle DNS responses when
"resolver" directive is used.

Impact
======

A remote attacker, able to provide DNS responses to a nginx instance,
could cause the execution of arbitrary code with the privileges of the
process or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All nginx users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-servers/nginx-1.20.1"

All nginx mainline users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot -v ">=www-servers/nginx-1.21.0:mainline"

References
==========

[ 1 ] CVE-2021-23017
       https://nvd.nist.gov/vuln/detail/CVE-2021-23017

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202105-38

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202105-38: nginx: Remote code execution

Summary

It was discovered that nginx did not properly handle DNS responses when "resolver" directive is used.

Resolution

All nginx users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/nginx-1.20.1"
All nginx mainline users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot -v ">=www-servers/nginx-1.21.0:mainline"

References

[ 1 ] CVE-2021-23017 https://nvd.nist.gov/vuln/detail/CVE-2021-23017

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202105-38

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: nginx: Remote code execution
Issued Date: May 26, 2021
Bugs: #792087
ID: 202105-38

Synopsis

A vulnerability in nginx could lead to remote code execution.

Background

nginx is a robust, small, and high performance HTTP and reverse proxy server.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 www-servers/nginx < 1.21.0 >= 1.20.1:0 >= 1.21.0:mainline

Impact

A remote attacker, able to provide DNS responses to a nginx instance, could cause the execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.