Gentoo: GLSA-202107-05: libxml2: Multiple vulnerabilities | LinuxSe...

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202107-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: libxml2: Multiple vulnerabilities
     Date: July 06, 2021
     Bugs: #749849, #790002
       ID: 202107-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in libxml2, the worst of which
could result in a Denial of Service condition.

Background
==========

libxml2 is the XML (eXtended Markup Language) C parser and toolkit
initially developed for the GNOME project.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-libs/libxml2             < 2.9.11                  >= 2.9.11 

Description
===========

Multiple vulnerabilities have been discovered in libxml2. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to process a specially crafted
XML document using an application linked against libxml2, possibly
resulting in a Denial of Service condition or obtaining sensitive
information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libxml2 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/libxml2-2.9.12-r3"

References
==========

[ 1 ] CVE-2020-24977
      https://nvd.nist.gov/vuln/detail/CVE-2020-24977
[ 2 ] CVE-2021-3516
      https://nvd.nist.gov/vuln/detail/CVE-2021-3516
[ 3 ] CVE-2021-3517
      https://nvd.nist.gov/vuln/detail/CVE-2021-3517
[ 4 ] CVE-2021-3518
      https://nvd.nist.gov/vuln/detail/CVE-2021-3518
[ 5 ] CVE-2021-3537
      https://nvd.nist.gov/vuln/detail/CVE-2021-3537
[ 6 ] CVE-2021-3541
      https://nvd.nist.gov/vuln/detail/CVE-2021-3541

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202107-05

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202107-05: libxml2: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in libxml2. Please review the CVE identifiers referenced below for details.

Resolution

All libxml2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/libxml2-2.9.12-r3"

References

[ 1 ] CVE-2020-24977 https://nvd.nist.gov/vuln/detail/CVE-2020-24977 [ 2 ] CVE-2021-3516 https://nvd.nist.gov/vuln/detail/CVE-2021-3516 [ 3 ] CVE-2021-3517 https://nvd.nist.gov/vuln/detail/CVE-2021-3517 [ 4 ] CVE-2021-3518 https://nvd.nist.gov/vuln/detail/CVE-2021-3518 [ 5 ] CVE-2021-3537 https://nvd.nist.gov/vuln/detail/CVE-2021-3537 [ 6 ] CVE-2021-3541 https://nvd.nist.gov/vuln/detail/CVE-2021-3541

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202107-05

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: libxml2: Multiple vulnerabilities
Date: July 06, 2021
Bugs: #749849, #790002
ID: 202107-05

Synopsis

Multiple vulnerabilities have been found in libxml2, the worst of which could result in a Denial of Service condition.

Background

libxml2 is the XML (eXtended Markup Language) C parser and toolkit initially developed for the GNOME project.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-libs/libxml2 < 2.9.11 >= 2.9.11

Impact

A remote attacker could entice a user to process a specially crafted XML document using an application linked against libxml2, possibly resulting in a Denial of Service condition or obtaining sensitive information.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.