Gentoo: GLSA-202107-09: Mozilla Firefox: Multiple vulnerabilities |...

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202107-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Mozilla Firefox: Multiple vulnerabilities
     Date: July 07, 2021
     Bugs: #794082
       ID: 202107-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Mozilla Firefox, the worst
of which could result in the arbitrary execution of code.

Background
==========

Mozilla Firefox is a popular open-source web browser from the Mozilla
project.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-client/firefox            < 89.0          >= 78.11.0:0/esr78
                                                              >= 89.0
  2  www-client/firefox-bin        < 89.0          >= 78.11.0:0/esr78
                                                              >= 89.0
    -------------------------------------------------------------------
     2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in Mozilla Firefox.
Please review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Mozilla Firefox ESR users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-client/firefox-78.11.0"

All Mozilla Firefox ESR binary users should upgrade to the latest
version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-78.11.0"

All Mozilla Firefox users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-client/firefox-89.0"

All Mozilla Firefox binary users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-89.0"

References
==========

[ 1 ] CVE-2021-29959
      https://nvd.nist.gov/vuln/detail/CVE-2021-29959
[ 2 ] CVE-2021-29960
      https://nvd.nist.gov/vuln/detail/CVE-2021-29960
[ 3 ] CVE-2021-29961
      https://nvd.nist.gov/vuln/detail/CVE-2021-29961
[ 4 ] CVE-2021-29966
      https://nvd.nist.gov/vuln/detail/CVE-2021-29966

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202107-09

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202107-09: Mozilla Firefox: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in Mozilla Firefox. Please review the CVE identifiers referenced below for details.

Resolution

All Mozilla Firefox ESR users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-client/firefox-78.11.0"
All Mozilla Firefox ESR binary users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-78.11.0"
All Mozilla Firefox users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-client/firefox-89.0"
All Mozilla Firefox binary users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-89.0"

References

[ 1 ] CVE-2021-29959 https://nvd.nist.gov/vuln/detail/CVE-2021-29959 [ 2 ] CVE-2021-29960 https://nvd.nist.gov/vuln/detail/CVE-2021-29960 [ 3 ] CVE-2021-29961 https://nvd.nist.gov/vuln/detail/CVE-2021-29961 [ 4 ] CVE-2021-29966 https://nvd.nist.gov/vuln/detail/CVE-2021-29966

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202107-09

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: Mozilla Firefox: Multiple vulnerabilities
Date: July 07, 2021
Bugs: #794082
ID: 202107-09

Synopsis

Multiple vulnerabilities have been found in Mozilla Firefox, the worst of which could result in the arbitrary execution of code.

Background

Mozilla Firefox is a popular open-source web browser from the Mozilla project.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 www-client/firefox < 89.0 >= 78.11.0:0/esr78 >= 89.0 2 www-client/firefox-bin < 89.0 >= 78.11.0:0/esr78 >= 89.0 ------------------------------------------------------------------- 2 affected packages

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.