Gentoo: GLSA-202208-30: GNU Binutils: Multiple Vulnerabilities | Li...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202208-30
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: GNU Binutils: Multiple Vulnerabilities
     Date: August 14, 2022
     Bugs: #778545, #792342, #829304
       ID: 202208-30

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in Binutils, the worst of
which could result in denial of service.

Background
==========

The GNU Binutils are a collection of tools to create, modify and analyse
binary files. Many of the files use BFD, the Binary File Descriptor
library, to do low-level manipulation.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  sys-devel/binutils         < 2.38                        >= 2.38
  2  sys-libs/binutils-libs     < 2.38                        >= 2.38

Description
===========

Multiple vulnerabilities have been discovered in GNU Binutils. Please
review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Binutils users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-devel/binutils-2.38"

All Binutils library users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-libs/binutils-libs-2.38"

References
==========

[ 1 ] CVE-2021-3487
      https://nvd.nist.gov/vuln/detail/CVE-2021-3487
[ 2 ] CVE-2021-3530
      https://nvd.nist.gov/vuln/detail/CVE-2021-3530
[ 3 ] CVE-2021-3549
      https://nvd.nist.gov/vuln/detail/CVE-2021-3549
[ 4 ] CVE-2021-20197
      https://nvd.nist.gov/vuln/detail/CVE-2021-20197
[ 5 ] CVE-2021-20284
      https://nvd.nist.gov/vuln/detail/CVE-2021-20284
[ 6 ] CVE-2021-20294
      https://nvd.nist.gov/vuln/detail/CVE-2021-20294
[ 7 ] CVE-2021-45078
      https://nvd.nist.gov/vuln/detail/CVE-2021-45078

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202208-30

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202208-30: GNU Binutils: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been discovered in GNU Binutils. Please review the CVE identifiers referenced below for details.

Resolution

All Binutils users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=sys-devel/binutils-2.38"
All Binutils library users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=sys-libs/binutils-libs-2.38"

References

[ 1 ] CVE-2021-3487 https://nvd.nist.gov/vuln/detail/CVE-2021-3487 [ 2 ] CVE-2021-3530 https://nvd.nist.gov/vuln/detail/CVE-2021-3530 [ 3 ] CVE-2021-3549 https://nvd.nist.gov/vuln/detail/CVE-2021-3549 [ 4 ] CVE-2021-20197 https://nvd.nist.gov/vuln/detail/CVE-2021-20197 [ 5 ] CVE-2021-20284 https://nvd.nist.gov/vuln/detail/CVE-2021-20284 [ 6 ] CVE-2021-20294 https://nvd.nist.gov/vuln/detail/CVE-2021-20294 [ 7 ] CVE-2021-45078 https://nvd.nist.gov/vuln/detail/CVE-2021-45078

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202208-30

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: GNU Binutils: Multiple Vulnerabilities
Date: August 14, 2022
Bugs: #778545, #792342, #829304
ID: 202208-30

Synopsis

Multiple vulnerabilities have been discovered in Binutils, the worst of which could result in denial of service.

Background

The GNU Binutils are a collection of tools to create, modify and analyse binary files. Many of the files use BFD, the Binary File Descriptor library, to do low-level manipulation.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 sys-devel/binutils < 2.38 >= 2.38 2 sys-libs/binutils-libs < 2.38 >= 2.38

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.