Gentoo: GLSA-202208-31: GStreamer, GStreamer Plugins: Multiple Vuln...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202208-31
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: GStreamer, GStreamer Plugins: Multiple Vulnerabilities
     Date: August 14, 2022
     Bugs: #766336, #785652, #785655, #785658, #785661, #835368, #843770, #765163
       ID: 202208-31

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in GStreamer and its plugins,
the worst of which could result in arbitrary code execution.

Background
==========

GStreamer is an open source multimedia framework.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  media-libs/gst-plugins-bad < 1.16.3                    >= 1.16.3
  2  media-libs/gst-plugins-base< 1.18.4                    >= 1.18.4
  3  media-libs/gst-plugins-good< 1.18.4                    >= 1.18.4
  4  media-libs/gst-plugins-ugly< 1.18.4                    >= 1.18.4
  5  media-libs/gstreamer       < 1.20.2                    >= 1.20.2
  6  media-plugins/gst-plugins-libav< 1.18.4                >= 1.18.4

Description
===========

Multiple vulnerabilities have been found in GStreamer and its plugins.
Please review the CVE and GStreamer-SA identifiers referenced below for
details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GStreamer users should update to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/gstreamer-1.20.2"

All gst-plugins-bad users should update to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-bad-1.20.2"

All gst-plugins-good users should update to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-good-1.20.2"

All gst-plugins-ugly users should update to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-ugly-1.20.2"

All gst-plugins-base users should update to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-base-1.20.2"

All gst-plugins-libav users should update to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-plugins/gst-plugins-libav-1.20.2"

References
==========

[ 1 ] CVE-2021-3185
      https://nvd.nist.gov/vuln/detail/CVE-2021-3185
[ 2 ] CVE-2021-3497
      https://nvd.nist.gov/vuln/detail/CVE-2021-3497
[ 3 ] CVE-2021-3498
      https://nvd.nist.gov/vuln/detail/CVE-2021-3498
[ 4 ] CVE-2021-3522
      https://nvd.nist.gov/vuln/detail/CVE-2021-3522
[ 5 ] GStreamer-SA-2021-0001
[ 6 ] GStreamer-SA-2021-0002
[ 7 ] GStreamer-SA-2021-0004
[ 8 ] GStreamer-SA-2021-0005

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202208-31

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202208-31: GStreamer, GStreamer Plugins: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been found in GStreamer and its plugins. Please review the CVE and GStreamer-SA identifiers referenced below for details.

Resolution

All GStreamer users should update to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/gstreamer-1.20.2"
All gst-plugins-bad users should update to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-bad-1.20.2"
All gst-plugins-good users should update to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-good-1.20.2"
All gst-plugins-ugly users should update to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-ugly-1.20.2"
All gst-plugins-base users should update to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-base-1.20.2"
All gst-plugins-libav users should update to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-plugins/gst-plugins-libav-1.20.2"

References

[ 1 ] CVE-2021-3185 https://nvd.nist.gov/vuln/detail/CVE-2021-3185 [ 2 ] CVE-2021-3497 https://nvd.nist.gov/vuln/detail/CVE-2021-3497 [ 3 ] CVE-2021-3498 https://nvd.nist.gov/vuln/detail/CVE-2021-3498 [ 4 ] CVE-2021-3522 https://nvd.nist.gov/vuln/detail/CVE-2021-3522 [ 5 ] GStreamer-SA-2021-0001 [ 6 ] GStreamer-SA-2021-0002 [ 7 ] GStreamer-SA-2021-0004 [ 8 ] GStreamer-SA-2021-0005

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202208-31

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: GStreamer, GStreamer Plugins: Multiple Vulnerabilities
Date: August 14, 2022
Bugs: #766336, #785652, #785655, #785658, #785661, #835368, #843770, #765163
ID: 202208-31

Synopsis

Multiple vulnerabilities have been found in GStreamer and its plugins, the worst of which could result in arbitrary code execution.

Background

GStreamer is an open source multimedia framework.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 media-libs/gst-plugins-bad < 1.16.3 >= 1.16.3 2 media-libs/gst-plugins-base< 1.18.4 >= 1.18.4 3 media-libs/gst-plugins-good< 1.18.4 >= 1.18.4 4 media-libs/gst-plugins-ugly< 1.18.4 >= 1.18.4 5 media-libs/gstreamer < 1.20.2 >= 1.20.2 6 media-plugins/gst-plugins-libav< 1.18.4 >= 1.18.4

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.