Gentoo: GLSA-202208-33: Gnome Shell, gettext, libcroco: Multiple Vu...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202208-33
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Gnome Shell, gettext, libcroco: Multiple Vulnerabilities
     Date: August 21, 2022
     Bugs: #722752, #755848, #769998
       ID: 202208-33

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability has been found in libcroco which could result in denial
of service.

Background
==========

GNOME Shell provides core user interface functions for the GNOME
desktop, like switching to windows and launching applications.

gettext contains the GNU locale utilities.

libcroco is a standalone CSS2 parsing and manipulation library.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-libs/libcroco          < 0.6.13                    >= 0.6.13
  2  gnome-base/gnome-shell     < 3.36.7                    >= 3.36.7
  3  sys-devel/gettext          < 0.21                        >= 0.21

Description
===========

The cr_parser_parse_any_core function in libcroco's cr-parser.c does not
limit recursion, leading to a denial of service via a stack overflow
when trying to parse crafted CSS.

Gnome Shell and gettext bundle libcroco in their own sources and thus
are potentially vulnerable as well.

Impact
======

An attacker with control over the input to the library can cause a denial of service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All gettext users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-devel/gettext-0.21"

All Gnome Shell users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=gnome-base/gnome-shell-3.36.7"

All libcroco users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/libcroco-0.6.13"

References
==========

[ 1 ] CVE-2020-12825
      https://nvd.nist.gov/vuln/detail/CVE-2020-12825

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202208-33

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202208-33: Gnome Shell, gettext, libcroco: Multiple Vulnerabilities

Summary

The cr_parser_parse_any_core function in libcroco's cr-parser.c does not limit recursion, leading to a denial of service via a stack overflow when trying to parse crafted CSS.
Gnome Shell and gettext bundle libcroco in their own sources and thus are potentially vulnerable as well.

Resolution

All gettext users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=sys-devel/gettext-0.21"
All Gnome Shell users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=gnome-base/gnome-shell-3.36.7"
All libcroco users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/libcroco-0.6.13"

References

[ 1 ] CVE-2020-12825 https://nvd.nist.gov/vuln/detail/CVE-2020-12825

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202208-33

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: Gnome Shell, gettext, libcroco: Multiple Vulnerabilities
Date: August 21, 2022
Bugs: #722752, #755848, #769998
ID: 202208-33

Synopsis

A vulnerability has been found in libcroco which could result in denial of service.

Background

GNOME Shell provides core user interface functions for the GNOME desktop, like switching to windows and launching applications.
gettext contains the GNU locale utilities.
libcroco is a standalone CSS2 parsing and manipulation library.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-libs/libcroco < 0.6.13 >= 0.6.13 2 gnome-base/gnome-shell < 3.36.7 >= 3.36.7 3 sys-devel/gettext < 0.21 >= 0.21

Impact

An attacker with control over the input to the library can cause a denial of service.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.