Gentoo: GLSA-202209-26: Go: Multiple Vulnerabilities | LinuxSecurit...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202209-26
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: Go: Multiple Vulnerabilities
     Date: September 29, 2022
     Bugs: #869002
       ID: 202209-26

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in Go, the worst of which
could result in denial of service.

Background
==========

Go is an open source programming language that makes it easy to build
simple, reliable, and efficient software.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-lang/go                < 1.18.6                    >= 1.18.6

Description
===========

Multiple vulnerabilities have been discovered in Go. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Go users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/go-1.18.6"

In addition, users using Portage 3.0.9 or later should ensure that
packages with Go binaries have no vulnerable code statically linked into
their binaries by rebuilding the @golang-rebuild set:

  # emerge --ask --oneshot --verbose @golang-rebuild

References
==========

[ 1 ] CVE-2022-27664
      https://nvd.nist.gov/vuln/detail/CVE-2022-27664
[ 2 ] CVE-2022-32190
      https://nvd.nist.gov/vuln/detail/CVE-2022-32190

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202209-26

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202209-26: Go: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been discovered in Go. Please review the CVE identifiers referenced below for details.

Resolution

All Go users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/go-1.18.6"
In addition, users using Portage 3.0.9 or later should ensure that packages with Go binaries have no vulnerable code statically linked into their binaries by rebuilding the @golang-rebuild set:
# emerge --ask --oneshot --verbose @golang-rebuild

References

[ 1 ] CVE-2022-27664 https://nvd.nist.gov/vuln/detail/CVE-2022-27664 [ 2 ] CVE-2022-32190 https://nvd.nist.gov/vuln/detail/CVE-2022-32190

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202209-26

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: Go: Multiple Vulnerabilities
Date: September 29, 2022
Bugs: #869002
ID: 202209-26

Synopsis

Multiple vulnerabilities have been discovered in Go, the worst of which could result in denial of service.

Background

Go is an open source programming language that makes it easy to build simple, reliable, and efficient software.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-lang/go < 1.18.6 >= 1.18.6

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.