Gentoo: GLSA-202209-21: Poppler: Arbitrary Code Execution | LinuxSe...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202209-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Poppler: Arbitrary Code Execution
     Date: September 29, 2022
     Bugs: #867958
       ID: 202209-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability has been discovered in Poppler which could allow for
arbitrary code execution.

Background
==========

Poppler is a PDF rendering library based on the xpdf-3.0 code base.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  app-text/poppler           < 22.09.0                  >= 22.09.0

Description
===========

Multiple vulnerabilities have been discovered in Poppler. Please review
the CVE identifiers referenced below for details.

Impact
======

Processing a specially crafted PDF file or JBIG2 image could lead to a
crash or the execution of arbitrary code.

Workaround
==========

Avoid opening untrusted PDFs.

Resolution
==========

All Poppler users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-text/poppler-22.09.0"

References
==========

[ 1 ] CVE-2021-30860
      https://nvd.nist.gov/vuln/detail/CVE-2021-30860
[ 2 ] CVE-2022-38784
      https://nvd.nist.gov/vuln/detail/CVE-2022-38784

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202209-21

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202209-21: Poppler: Arbitrary Code Execution

Summary

Multiple vulnerabilities have been discovered in Poppler. Please review the CVE identifiers referenced below for details.

Resolution

All Poppler users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=app-text/poppler-22.09.0"

References

[ 1 ] CVE-2021-30860 https://nvd.nist.gov/vuln/detail/CVE-2021-30860 [ 2 ] CVE-2022-38784 https://nvd.nist.gov/vuln/detail/CVE-2022-38784

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202209-21

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: Poppler: Arbitrary Code Execution
Date: September 29, 2022
Bugs: #867958
ID: 202209-21

Synopsis

A vulnerability has been discovered in Poppler which could allow for arbitrary code execution.

Background

Poppler is a PDF rendering library based on the xpdf-3.0 code base.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 app-text/poppler < 22.09.0 >= 22.09.0

Impact

Processing a specially crafted PDF file or JBIG2 image could lead to a crash or the execution of arbitrary code.

Workaround

Avoid opening untrusted PDFs.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.