Gentoo: GLSA-202211-03: PHP: Multiple Vulnerabilities | LinuxSecuri...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202211-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                          https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
   Title: PHP: Multiple Vulnerabilities
    Date: November 19, 2022
    Bugs: #867913, #873376, #877853
      ID: 202211-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PHP, the worst of which
could result in arbitrary code execution.

Background
==========

PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.

Affected packages
=================

-------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-lang/php      < 7.4.33:7.4             >= 7.4.33:7.4
                                < 8.0.25:8.0             >= 8.0.25:8.0
                                < 8.1.12:8.1               >= 8.1.12:8.1

Description
===========

Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHP 7.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-7.4.33"

All PHP 8.0 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-8.0.25"

All PHP 8.1 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-8.1.12"

References
==========

[ 1 ] CVE-2022-31628
     https://nvd.nist.gov/vuln/detail/CVE-2022-31628
[ 2 ] CVE-2022-31629
     https://nvd.nist.gov/vuln/detail/CVE-2022-31629
[ 3 ] CVE-2022-31630
     https://nvd.nist.gov/vuln/detail/CVE-2022-31630
[ 4 ] CVE-2022-37454
     https://nvd.nist.gov/vuln/detail/CVE-2022-37454

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202211-03

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202211-03: PHP: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.

Resolution

All PHP 7.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-7.4.33"
All PHP 8.0 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-8.0.25"
All PHP 8.1 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-8.1.12"

References

[ 1 ] CVE-2022-31628 https://nvd.nist.gov/vuln/detail/CVE-2022-31628 [ 2 ] CVE-2022-31629 https://nvd.nist.gov/vuln/detail/CVE-2022-31629 [ 3 ] CVE-2022-31630 https://nvd.nist.gov/vuln/detail/CVE-2022-31630 [ 4 ] CVE-2022-37454 https://nvd.nist.gov/vuln/detail/CVE-2022-37454

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202211-03

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: PHP: Multiple Vulnerabilities
Date: November 19, 2022
Bugs: #867913, #873376, #877853
ID: 202211-03

Synopsis

Multiple vulnerabilities have been found in PHP, the worst of which could result in arbitrary code execution.

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-lang/php < 7.4.33:7.4 >= 7.4.33:7.4 < 8.0.25:8.0 >= 8.0.25:8.0 < 8.1.12:8.1 >= 8.1.12:8.1

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.