Gentoo: GLSA-202305-25: OWASP ModSecurity Core Rule Set: Multiple V...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202305-25
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: OWASP ModSecurity Core Rule Set: Multiple Vulnerabilities
     Date: May 21, 2023
     Bugs: #822003, #872077
       ID: 202305-25

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in ModSecurity Core Rule
Set, the worst of which could result in bypassing the WAF.

Background
==========

Modsecurity Core Rule Set is the OWASP ModSecurity Core Rule Set.

Affected packages
=================

Package                     Vulnerable    Unaffected
--------------------------  ------------  ------------
www-apache/modsecurity-crs  < 3.3.4       >= 3.3.4

Description
===========

Multiple vulnerabilities have been discovered in OWASP ModSecurity Core
Rule Set. Please review the CVE identifiers referenced below for
details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All OWASP ModSecurity Core Rule Set users should upgrade to the latest
version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apache/modsecurity-crs-3.3.4"

References
==========

[ 1 ] CVE-2021-35368
      https://nvd.nist.gov/vuln/detail/CVE-2021-35368
[ 2 ] CVE-2022-39955
      https://nvd.nist.gov/vuln/detail/CVE-2022-39955
[ 3 ] CVE-2022-39956
      https://nvd.nist.gov/vuln/detail/CVE-2022-39956
[ 4 ] CVE-2022-39957
      https://nvd.nist.gov/vuln/detail/CVE-2022-39957
[ 5 ] CVE-2022-39958
      https://nvd.nist.gov/vuln/detail/CVE-2022-39958

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202305-25

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2023 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202305-25: OWASP ModSecurity Core Rule Set: Multiple Vulnerabilities

Multiple vulnerabilities have been discovered in ModSecurity Core Rule Set, the worst of which could result in bypassing the WAF.

Summary

Multiple vulnerabilities have been discovered in OWASP ModSecurity Core Rule Set. Please review the CVE identifiers referenced below for details.

Resolution

All OWASP ModSecurity Core Rule Set users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-apache/modsecurity-crs-3.3.4"

References

[ 1 ] CVE-2021-35368 https://nvd.nist.gov/vuln/detail/CVE-2021-35368 [ 2 ] CVE-2022-39955 https://nvd.nist.gov/vuln/detail/CVE-2022-39955 [ 3 ] CVE-2022-39956 https://nvd.nist.gov/vuln/detail/CVE-2022-39956 [ 4 ] CVE-2022-39957 https://nvd.nist.gov/vuln/detail/CVE-2022-39957 [ 5 ] CVE-2022-39958 https://nvd.nist.gov/vuln/detail/CVE-2022-39958

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202305-25

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: OWASP ModSecurity Core Rule Set: Multiple Vulnerabilities
Date: May 21, 2023
Bugs: #822003, #872077
ID: 202305-25

Synopsis

Multiple vulnerabilities have been discovered in ModSecurity Core Rule Set, the worst of which could result in bypassing the WAF.

Background

Modsecurity Core Rule Set is the OWASP ModSecurity Core Rule Set.

Affected Packages

Package Vulnerable Unaffected -------------------------- ------------ ------------ www-apache/modsecurity-crs < 3.3.4 >= 3.3.4

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.