Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202309-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: Wireshark: Multiple Vulnerabilities
     Date: September 17, 2023
     Bugs: #878421, #899548, #904248, #907133
       ID: 202309-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Wireshark, the worst of
which could result in denial of service.

Background
==========

Wireshark is a versatile network protocol analyzer.

Affected packages
=================

Package                 Vulnerable    Unaffected
----------------------  ------------  ------------
net-analyzer/wireshark  < 4.0.6       >= 4.0.6

Description
===========

Multiple vulnerabilities have been discovered in Wireshark. Please
review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Wireshark users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-4.0.6"

References
==========

[ 1 ] CVE-2022-3725
      https://nvd.nist.gov/vuln/detail/CVE-2022-3725
[ 2 ] CVE-2023-0666
      https://nvd.nist.gov/vuln/detail/CVE-2023-0666
[ 3 ] CVE-2023-0667
      https://nvd.nist.gov/vuln/detail/CVE-2023-0667
[ 4 ] CVE-2023-0668
      https://nvd.nist.gov/vuln/detail/CVE-2023-0668
[ 5 ] CVE-2023-1161
      https://nvd.nist.gov/vuln/detail/CVE-2023-1161
[ 6 ] CVE-2023-1992
      https://nvd.nist.gov/vuln/detail/CVE-2023-1992
[ 7 ] CVE-2023-1993
      https://nvd.nist.gov/vuln/detail/CVE-2023-1993
[ 8 ] CVE-2023-1994
      https://nvd.nist.gov/vuln/detail/CVE-2023-1994
[ 9 ] CVE-2023-2854
      https://nvd.nist.gov/vuln/detail/CVE-2023-2854
[ 10 ] CVE-2023-2855
      https://nvd.nist.gov/vuln/detail/CVE-2023-2855
[ 11 ] CVE-2023-2856
      https://nvd.nist.gov/vuln/detail/CVE-2023-2856
[ 12 ] CVE-2023-2857
      https://nvd.nist.gov/vuln/detail/CVE-2023-2857
[ 13 ] CVE-2023-2858
      https://nvd.nist.gov/vuln/detail/CVE-2023-2858
[ 14 ] CVE-2023-2879
      https://nvd.nist.gov/vuln/detail/CVE-2023-2879
[ 15 ] CVE-2023-2952
      https://nvd.nist.gov/vuln/detail/CVE-2023-2952
[ 16 ] WNPA-SEC-2022-07
[ 17 ] WNPA-SEC-2023-08
[ 18 ] WNPA-SEC-2023-09
[ 19 ] WNPA-SEC-2023-10
[ 20 ] WNPA-SEC-2023-11

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202309-02

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2023 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-202309-02: Wireshark: Multiple Vulnerabilities

Multiple vulnerabilities have been found in Wireshark, the worst of which could result in denial of service.

Summary

Multiple vulnerabilities have been discovered in Wireshark. Please review the CVE identifiers referenced below for details.

Resolution

All Wireshark users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-4.0.6"

References

[ 1 ] CVE-2022-3725 https://nvd.nist.gov/vuln/detail/CVE-2022-3725 [ 2 ] CVE-2023-0666 https://nvd.nist.gov/vuln/detail/CVE-2023-0666 [ 3 ] CVE-2023-0667 https://nvd.nist.gov/vuln/detail/CVE-2023-0667 [ 4 ] CVE-2023-0668 https://nvd.nist.gov/vuln/detail/CVE-2023-0668 [ 5 ] CVE-2023-1161 https://nvd.nist.gov/vuln/detail/CVE-2023-1161 [ 6 ] CVE-2023-1992 https://nvd.nist.gov/vuln/detail/CVE-2023-1992 [ 7 ] CVE-2023-1993 https://nvd.nist.gov/vuln/detail/CVE-2023-1993 [ 8 ] CVE-2023-1994 https://nvd.nist.gov/vuln/detail/CVE-2023-1994 [ 9 ] CVE-2023-2854 https://nvd.nist.gov/vuln/detail/CVE-2023-2854 [ 10 ] CVE-2023-2855 https://nvd.nist.gov/vuln/detail/CVE-2023-2855 [ 11 ] CVE-2023-2856 https://nvd.nist.gov/vuln/detail/CVE-2023-2856 [ 12 ] CVE-2023-2857 https://nvd.nist.gov/vuln/detail/CVE-2023-2857 [ 13 ] CVE-2023-2858 https://nvd.nist.gov/vuln/detail/CVE-2023-2858 [ 14 ] CVE-2023-2879 https://nvd.nist.gov/vuln/detail/CVE-2023-2879 [ 15 ] CVE-2023-2952 https://nvd.nist.gov/vuln/detail/CVE-2023-2952 [ 16 ] WNPA-SEC-2022-07 [ 17 ] WNPA-SEC-2023-08 [ 18 ] WNPA-SEC-2023-09 [ 19 ] WNPA-SEC-2023-10 [ 20 ] WNPA-SEC-2023-11

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202309-02

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: Wireshark: Multiple Vulnerabilities
Date: September 17, 2023
Bugs: #878421, #899548, #904248, #907133
ID: 202309-02

Synopsis

Multiple vulnerabilities have been found in Wireshark, the worst of which could result in denial of service.

Background

Wireshark is a versatile network protocol analyzer.

Affected Packages

Package Vulnerable Unaffected ---------------------- ------------ ------------ net-analyzer/wireshark < 4.0.6 >= 4.0.6

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Related News