- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202312-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: NASM: Multiple Vulnerabilities
     Date: December 22, 2023
     Bugs: #686720, #903755
       ID: 202312-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in NASM, the worst of
which could lead to arbitrary code execution.

Background
==========

NASM is a 80x86 assembler that has been created for portability and
modularity. NASM supports Pentium, P6, SSE MMX, and 3DNow extensions. It
also supports a wide range of objects formats (ELF, a.out, COFF, etc),
and has its own disassembler.

Affected packages
=================

Package        Vulnerable    Unaffected
-------------  ------------  ------------
dev-lang/nasm  < 2.16.01     >= 2.16.01

Description
===========

Multiple vulnerabilities have been discovered in NASM. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All NASM users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/nasm-2.16.01"

References
==========

[ 1 ] CVE-2019-8343
      https://nvd.nist.gov/vuln/detail/CVE-2019-8343
[ 2 ] CVE-2020-21528
      https://nvd.nist.gov/vuln/detail/CVE-2020-21528
[ 3 ] CVE-2022-44370
      https://nvd.nist.gov/vuln/detail/CVE-2022-44370

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202312-09

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2023 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-202312-09: NASM: Multiple Vulnerabilities

Multiple vulnerabilities have been discovered in NASM, the worst of which could lead to arbitrary code execution.

Summary

Multiple vulnerabilities have been discovered in NASM. Please review the CVE identifiers referenced below for details.

Resolution

All NASM users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/nasm-2.16.01"

References

[ 1 ] CVE-2019-8343 https://nvd.nist.gov/vuln/detail/CVE-2019-8343 [ 2 ] CVE-2020-21528 https://nvd.nist.gov/vuln/detail/CVE-2020-21528 [ 3 ] CVE-2022-44370 https://nvd.nist.gov/vuln/detail/CVE-2022-44370

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202312-09

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: NASM: Multiple Vulnerabilities
Date: December 22, 2023
Bugs: #686720, #903755
ID: 202312-09

Synopsis

Multiple vulnerabilities have been discovered in NASM, the worst of which could lead to arbitrary code execution.

Background

NASM is a 80x86 assembler that has been created for portability and modularity. NASM supports Pentium, P6, SSE MMX, and 3DNow extensions. It also supports a wide range of objects formats (ELF, a.out, COFF, etc), and has its own disassembler.

Affected Packages

Package Vulnerable Unaffected ------------- ------------ ------------ dev-lang/nasm < 2.16.01 >= 2.16.01

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo