- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202312-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: FFmpeg: Multiple Vulnerabilities
     Date: December 23, 2023
     Bugs: #795696, #842267, #881523, #903805
       ID: 202312-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilitiies have been discovered in FFmpeg, the worst of
which could lead to code execution

Background
==========

FFmpeg is a complete solution to record, convert and stream audio and
video.

Affected packages
=================

Package             Vulnerable    Unaffected
------------------  ------------  ------------
media-video/ffmpeg  < 6.0         >= 6.0

Description
===========

Multiple vulnerabilities have been discovered in FFmpeg. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All FFmpeg 4 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-video/ffmpeg-4.4.3"

All FFmpeg 6 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-video/ffmpeg-6.0"

References
==========

[ 1 ] CVE-2021-33815
      https://nvd.nist.gov/vuln/detail/CVE-2021-33815
[ 2 ] CVE-2021-38171
      https://nvd.nist.gov/vuln/detail/CVE-2021-38171
[ 3 ] CVE-2021-38291
      https://nvd.nist.gov/vuln/detail/CVE-2021-38291
[ 4 ] CVE-2022-1475
      https://nvd.nist.gov/vuln/detail/CVE-2022-1475
[ 5 ] CVE-2022-3964
      https://nvd.nist.gov/vuln/detail/CVE-2022-3964
[ 6 ] CVE-2022-3965
      https://nvd.nist.gov/vuln/detail/CVE-2022-3965
[ 7 ] CVE-2022-48434
      https://nvd.nist.gov/vuln/detail/CVE-2022-48434

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202312-14

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2023 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-202312-14: FFmpeg: Multiple Vulnerabilities

Multiple vulnerabilitiies have been discovered in FFmpeg, the worst of which could lead to code execution

Summary

Multiple vulnerabilities have been discovered in FFmpeg. Please review the CVE identifiers referenced below for details.

Resolution

All FFmpeg 4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-video/ffmpeg-4.4.3"
All FFmpeg 6 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-video/ffmpeg-6.0"

References

[ 1 ] CVE-2021-33815 https://nvd.nist.gov/vuln/detail/CVE-2021-33815 [ 2 ] CVE-2021-38171 https://nvd.nist.gov/vuln/detail/CVE-2021-38171 [ 3 ] CVE-2021-38291 https://nvd.nist.gov/vuln/detail/CVE-2021-38291 [ 4 ] CVE-2022-1475 https://nvd.nist.gov/vuln/detail/CVE-2022-1475 [ 5 ] CVE-2022-3964 https://nvd.nist.gov/vuln/detail/CVE-2022-3964 [ 6 ] CVE-2022-3965 https://nvd.nist.gov/vuln/detail/CVE-2022-3965 [ 7 ] CVE-2022-48434 https://nvd.nist.gov/vuln/detail/CVE-2022-48434

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202312-14

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: FFmpeg: Multiple Vulnerabilities
Date: December 23, 2023
Bugs: #795696, #842267, #881523, #903805
ID: 202312-14

Synopsis

Multiple vulnerabilitiies have been discovered in FFmpeg, the worst of which could lead to code execution

Background

FFmpeg is a complete solution to record, convert and stream audio and video.

Affected Packages

Package Vulnerable Unaffected ------------------ ------------ ------------ media-video/ffmpeg < 6.0 >= 6.0

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo