- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202401-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: c-ares: Multiple Vulnerabilities
     Date: January 05, 2024
     Bugs: #807604, #807775, #892489, #905341
       ID: 202401-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in c-ares, the worst of which
could result in the loss of confidentiality or integrity.

Background
==========

c-ares is a C library for asynchronous DNS requests (including name
resolves).

Affected packages
=================

Package         Vulnerable    Unaffected
--------------  ------------  ------------
net-dns/c-ares  < 1.19.0      >= 1.19.0

Description
===========

Multiple vulnerabilities have been discovered in c-ares. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All c-ares users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-dns/c-ares-1.19.0"

References
==========

[ 1 ] CVE-2021-3672
      https://nvd.nist.gov/vuln/detail/CVE-2021-3672
[ 2 ] CVE-2021-22930
      https://nvd.nist.gov/vuln/detail/CVE-2021-22930
[ 3 ] CVE-2021-22931
      https://nvd.nist.gov/vuln/detail/CVE-2021-22931
[ 4 ] CVE-2021-22939
      https://nvd.nist.gov/vuln/detail/CVE-2021-22939
[ 5 ] CVE-2021-22940
      https://nvd.nist.gov/vuln/detail/CVE-2021-22940
[ 6 ] CVE-2022-4904
      https://nvd.nist.gov/vuln/detail/CVE-2022-4904

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202401-02

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-202401-02: c-ares: Multiple Vulnerabilities

Multiple vulnerabilities have been found in c-ares, the worst of which could result in the loss of confidentiality or integrity.

Summary

Multiple vulnerabilities have been discovered in c-ares. Please review the CVE identifiers referenced below for details.

Resolution

All c-ares users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-dns/c-ares-1.19.0"

References

[ 1 ] CVE-2021-3672 https://nvd.nist.gov/vuln/detail/CVE-2021-3672 [ 2 ] CVE-2021-22930 https://nvd.nist.gov/vuln/detail/CVE-2021-22930 [ 3 ] CVE-2021-22931 https://nvd.nist.gov/vuln/detail/CVE-2021-22931 [ 4 ] CVE-2021-22939 https://nvd.nist.gov/vuln/detail/CVE-2021-22939 [ 5 ] CVE-2021-22940 https://nvd.nist.gov/vuln/detail/CVE-2021-22940 [ 6 ] CVE-2022-4904 https://nvd.nist.gov/vuln/detail/CVE-2022-4904

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202401-02

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: c-ares: Multiple Vulnerabilities
Date: January 05, 2024
Bugs: #807604, #807775, #892489, #905341
ID: 202401-02

Synopsis

Multiple vulnerabilities have been found in c-ares, the worst of which could result in the loss of confidentiality or integrity.

Background

c-ares is a C library for asynchronous DNS requests (including name resolves).

Affected Packages

Package Vulnerable Unaffected -------------- ------------ ------------ net-dns/c-ares < 1.19.0 >= 1.19.0

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo