- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202402-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: libxml2: Multiple Vulnerabilities
     Date: February 09, 2024
     Bugs: #904202, #905399, #915351, #923806
       ID: 202402-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple denial of service vulnerabilities have been found in libxml2.

Background
==========

libxml2 is the XML C parser and toolkit developed for the GNOME project.

Affected packages
=================

Package           Vulnerable    Unaffected
----------------  ------------  ------------
dev-libs/libxml2  < 2.12.5      >= 2.12.5

Description
===========

Multiple vulnerabilities have been discovered in libxml2. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libxml2 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/libxml2-2.12.5"

If you cannot update to libxml2-2.12 yet you can update to the latest
2.11 version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/libxml2-2.11.7 =dev-libs/libxml2-2.11*"

References
==========

[ 1 ] CVE-2023-28484
      https://nvd.nist.gov/vuln/detail/CVE-2023-28484
[ 2 ] CVE-2023-29469
      https://nvd.nist.gov/vuln/detail/CVE-2023-29469
[ 3 ] CVE-2023-45322
      https://nvd.nist.gov/vuln/detail/CVE-2023-45322
[ 4 ] CVE-2024-25062
      https://nvd.nist.gov/vuln/detail/CVE-2024-25062

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202402-11

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-202402-11: libxml2: Multiple Vulnerabilities

Multiple denial of service vulnerabilities have been found in libxml2.

Summary

Multiple vulnerabilities have been discovered in libxml2. Please review the CVE identifiers referenced below for details.

Resolution

All libxml2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/libxml2-2.12.5"
If you cannot update to libxml2-2.12 yet you can update to the latest 2.11 version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/libxml2-2.11.7 =dev-libs/libxml2-2.11*"

References

[ 1 ] CVE-2023-28484 https://nvd.nist.gov/vuln/detail/CVE-2023-28484 [ 2 ] CVE-2023-29469 https://nvd.nist.gov/vuln/detail/CVE-2023-29469 [ 3 ] CVE-2023-45322 https://nvd.nist.gov/vuln/detail/CVE-2023-45322 [ 4 ] CVE-2024-25062 https://nvd.nist.gov/vuln/detail/CVE-2024-25062

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202402-11

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: libxml2: Multiple Vulnerabilities
Date: February 09, 2024
Bugs: #904202, #905399, #915351, #923806
ID: 202402-11

Synopsis

Multiple denial of service vulnerabilities have been found in libxml2.

Background

libxml2 is the XML C parser and toolkit developed for the GNOME project.

Affected Packages

Package Vulnerable Unaffected ---------------- ------------ ------------ dev-libs/libxml2 < 2.12.5 >= 2.12.5

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo