Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202402-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Exim: Multiple Vulnerabilities
     Date: February 18, 2024
     Bugs: #914923, #921520
       ID: 202402-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in Exim, the worst of
which can lead to remote code execution.

Background
==========

Exim is a message transfer agent (MTA) designed to be a a highly
configurable, drop-in replacement for sendmail.

Affected packages
=================

Package        Vulnerable    Unaffected
-------------  ------------  ------------
mail-mta/exim  < 4.97.1      >= 4.97.1

Description
===========

Multiple vulnerabilities have been discovered in Exim. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Exim users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=mail-mta/exim-4.97.1"

References
==========

[ 1 ] CVE-2023-42114
      https://nvd.nist.gov/vuln/detail/CVE-2023-42114
[ 2 ] CVE-2023-42115
      https://nvd.nist.gov/vuln/detail/CVE-2023-42115
[ 3 ] CVE-2023-42116
      https://nvd.nist.gov/vuln/detail/CVE-2023-42116
[ 4 ] CVE-2023-42117
      https://nvd.nist.gov/vuln/detail/CVE-2023-42117
[ 5 ] CVE-2023-42119
      https://nvd.nist.gov/vuln/detail/CVE-2023-42119
[ 6 ] CVE-2023-51766
      https://nvd.nist.gov/vuln/detail/CVE-2023-51766
[ 7 ] ZDI-CAN-17433
[ 8 ] ZDI-CAN-17434
[ 9 ] ZDI-CAN-17515
[ 10 ] ZDI-CAN-17554
[ 11 ] ZDI-CAN-17643

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202402-18

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-202402-18: Exim: Multiple Vulnerabilities

Multiple vulnerabilities have been discovered in Exim, the worst of which can lead to remote code execution.

Summary

Multiple vulnerabilities have been discovered in Exim. Please review the CVE identifiers referenced below for details.

Resolution

All Exim users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=mail-mta/exim-4.97.1"

References

[ 1 ] CVE-2023-42114 https://nvd.nist.gov/vuln/detail/CVE-2023-42114 [ 2 ] CVE-2023-42115 https://nvd.nist.gov/vuln/detail/CVE-2023-42115 [ 3 ] CVE-2023-42116 https://nvd.nist.gov/vuln/detail/CVE-2023-42116 [ 4 ] CVE-2023-42117 https://nvd.nist.gov/vuln/detail/CVE-2023-42117 [ 5 ] CVE-2023-42119 https://nvd.nist.gov/vuln/detail/CVE-2023-42119 [ 6 ] CVE-2023-51766 https://nvd.nist.gov/vuln/detail/CVE-2023-51766 [ 7 ] ZDI-CAN-17433 [ 8 ] ZDI-CAN-17434 [ 9 ] ZDI-CAN-17515 [ 10 ] ZDI-CAN-17554 [ 11 ] ZDI-CAN-17643

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202402-18

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: Exim: Multiple Vulnerabilities
Date: February 18, 2024
Bugs: #914923, #921520
ID: 202402-18

Synopsis

Multiple vulnerabilities have been discovered in Exim, the worst of which can lead to remote code execution.

Background

Exim is a message transfer agent (MTA) designed to be a a highly configurable, drop-in replacement for sendmail.

Affected Packages

Package Vulnerable Unaffected ------------- ------------ ------------ mail-mta/exim < 4.97.1 >= 4.97.1

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Related News