- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202407-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: GNU Emacs, Org Mode: Multiple Vulnerabilities
     Date: July 01, 2024
     Bugs: #897950, #927820
       ID: 202407-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in GNU Emacs and Org Mode,
the worst of which could lead to arbitrary code execution.

Background
==========

GNU Emacs is a highly extensible and customizable text editor.

Affected packages
=================

Package             Vulnerable     Unaffected
------------------  -------------  --------------
app-editors/emacs   < 26.3-r16:26  >= 26.3-r16:26
                    < 27.2-r14:27  >= 27.2-r14:27
                    < 28.2-r10:28  >= 28.2-r10:28
                    < 29.2-r1:29   >= 29.2-r1:29
app-emacs/org-mode  < 9.6.23       >= 9.6.23

Description
===========

Multiple vulnerabilities have been discovered in GNU Emacs. Please
review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GNU Emacs users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-editors/emacs-29.3-r2"

All Org Mode users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emacs/org-mode-9.6.23"

References
==========

[ 1 ] CVE-2022-48337
      https://nvd.nist.gov/vuln/detail/CVE-2022-48337
[ 2 ] CVE-2022-48338
      https://nvd.nist.gov/vuln/detail/CVE-2022-48338
[ 3 ] CVE-2022-48339
      https://nvd.nist.gov/vuln/detail/CVE-2022-48339
[ 4 ] CVE-2024-30202
      https://nvd.nist.gov/vuln/detail/CVE-2024-30202
[ 5 ] CVE-2024-30203
      https://nvd.nist.gov/vuln/detail/CVE-2024-30203
[ 6 ] CVE-2024-30204
      https://nvd.nist.gov/vuln/detail/CVE-2024-30204
[ 7 ] CVE-2024-30205
      https://nvd.nist.gov/vuln/detail/CVE-2024-30205

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202407-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2024 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202407-08: GNU Emacs, Org Mode: Security Advisory Updates

Multiple vulnerabilities have been discovered in GNU Emacs and Org Mode, the worst of which could lead to arbitrary code execution.

Summary

Multiple vulnerabilities have been discovered in GNU Emacs. Please review the CVE identifiers referenced below for details.

Resolution

All GNU Emacs users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=app-editors/emacs-29.3-r2"
All Org Mode users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=app-emacs/org-mode-9.6.23"

References

[ 1 ] CVE-2022-48337 https://nvd.nist.gov/vuln/detail/CVE-2022-48337 [ 2 ] CVE-2022-48338 https://nvd.nist.gov/vuln/detail/CVE-2022-48338 [ 3 ] CVE-2022-48339 https://nvd.nist.gov/vuln/detail/CVE-2022-48339 [ 4 ] CVE-2024-30202 https://nvd.nist.gov/vuln/detail/CVE-2024-30202 [ 5 ] CVE-2024-30203 https://nvd.nist.gov/vuln/detail/CVE-2024-30203 [ 6 ] CVE-2024-30204 https://nvd.nist.gov/vuln/detail/CVE-2024-30204 [ 7 ] CVE-2024-30205 https://nvd.nist.gov/vuln/detail/CVE-2024-30205

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202407-08

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: GNU Emacs, Org Mode: Multiple Vulnerabilities
Date: July 01, 2024
Bugs: #897950, #927820
ID: 202407-08

Synopsis

Multiple vulnerabilities have been discovered in GNU Emacs and Org Mode, the worst of which could lead to arbitrary code execution.

Background

GNU Emacs is a highly extensible and customizable text editor.

Affected Packages

Package Vulnerable Unaffected ------------------ ------------- -------------- app-editors/emacs < 26.3-r16:26 >= 26.3-r16:26 < 27.2-r14:27 >= 27.2-r14:27 < 28.2-r10:28 >= 28.2-r10:28 < 29.2-r1:29 >= 29.2-r1:29 app-emacs/org-mode < 9.6.23 >= 9.6.23

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Related News