MGASA-2020-0016 - Updated memcached packages fix security vulnerability

Publication date: 05 Jan 2020
URL: https://advisories.mageia.org/MGASA-2020-0016.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2019-15026

Updated memcached packages fix security vulnerability:

memcached 1.5.16, when UNIX sockets are used, has a stack-based buffer
over-read in conn_to_str in memcached.c. (CVE-2019-15026)

This update adds the ability to recover the cache from disk.

References:
- https://bugs.mageia.org/show_bug.cgi?id=25953
- https://bugzilla.redhat.com/show_bug.cgi?id=1753862
- https://github.com/memcached/memcached/wiki/ReleaseNotes1518
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15026

SRPMS:
- 7/core/memcached-1.5.20-1.mga7