MGASA-2020-0240 - Updated json-c packages fix security vulnerability

Publication date: 29 May 2020
URL: https://advisories.mageia.org/MGASA-2020-0240.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2020-12762

Updated json-c package fixes security vulnerabilities:

It was discovered that json-c through 0.14 has an integer overflow
and out-of-bounds write via a large JSON file, as demonstrated by
printbuf_memappend (CVE-2020-12762).

References:
- https://bugs.mageia.org/show_bug.cgi?id=26623
- https://usn.ubuntu.com/4360-1/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12762

SRPMS:
- 7/core/json-c-0.13.1-2.2.mga7