MGASA-2020-0357 - Updated mutt packages fix security vulnerabilities

Publication date: 02 Sep 2020
URL: https://advisories.mageia.org/MGASA-2020-0357.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2020-14093,
     CVE-2020-14954

A potential IMAP Man-in-the-Middle attack via a PREAUTH response
(CVE-2020-14093).

Mutt was ignoring an expired certificate and was proceeding with a connection
(CVE-2020-14154).

A response injection due to a STARTTLS buffering issue which was affecting
IMAP, SMTP, and POP3 (CVE-2020-14954).

References:
- https://bugs.mageia.org/show_bug.cgi?id=26852
- https://www.debian.org/security/2020/dsa-4707
- https://www.debian.org/security/2020/dsa-4708
- https://lists.opensuse.org/opensuse-updates/2020-06/msg00165.html
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14093
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14954

SRPMS:
- 7/core/mutt-1.11.4-1.3.mga7