Mageia 2020-0376: cifs-utils security update | LinuxSecurity.com
MGASA-2020-0376 - Updated cifs-utils packages fix security vulnerability

Publication date: 27 Sep 2020
URL: https://advisories.mageia.org/MGASA-2020-0376.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2020-14342

The mount.cifs utility has a shell injection issue where one can embed shell
commands via the username mount option. Those commands will be run via popen()
in the context of the user calling mount (CVE-2020-14342).

References:
- https://bugs.mageia.org/show_bug.cgi?id=27315
- https://lists.samba.org/archive/samba-technical/2020-September/135747.html
- https://lists.suse.com/pipermail/sle-security-updates/2020-September/007471.html
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14342

SRPMS:
- 7/core/cifs-utils-6.9-6.1.mga7

Mageia 2020-0376: cifs-utils security update

The mount.cifs utility has a shell injection issue where one can embed shell commands via the username mount option

Summary

The mount.cifs utility has a shell injection issue where one can embed shell commands via the username mount option. Those commands will be run via popen() in the context of the user calling mount (CVE-2020-14342).

References

- https://bugs.mageia.org/show_bug.cgi?id=27315

- https://lists.samba.org/archive/samba-technical/2020-September/135747.html

- https://lists.suse.com/pipermail/sle-security-updates/2020-September/007471.html

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14342

Resolution

MGASA-2020-0376 - Updated cifs-utils packages fix security vulnerability

SRPMS

- 7/core/cifs-utils-6.9-6.1.mga7

Severity
Publication date: 27 Sep 2020
URL: https://advisories.mageia.org/MGASA-2020-0376.html
Type: security
CVE: CVE-2020-14342

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.