MGASA-2021-0059 - Updated dnsmasq packages fix security vulnerability

Publication date: 29 Jan 2021
URL: https://advisories.mageia.org/MGASA-2021-0059.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2020-25681,
     CVE-2020-25682,
     CVE-2020-25683,
     CVE-2020-25684,
     CVE-2020-25685,
     CVE-2020-25686,
     CVE-2020-25687

Multiples vulnerabilities  have been discovered in dnsmasq up to version 2.82:
- subtle errors in dnsmasq's protections against cache-poisoning attacks
(CVE-2020-25684, CVE-2020-25685 and CVE-2020-25686)
- buffer overflow in dnsmasq's DNSSEC code (CVE-2020-25681, 
CVE-2020-25682, CVE-2020-25683 and CVE-2020-25687)

References:
- https://bugs.mageia.org/show_bug.cgi?id=28169
- https://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2021q1/014599.html
- https://www.openwall.com/lists/oss-security/2021/01/19/1
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25681
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25682
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25683
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25684
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25685
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25686
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25687

SRPMS:
- 7/core/dnsmasq-2.83-1.mga7