MGASA-2021-0090 - Updated pix packages fix a security vulnerability

Publication date: 28 Feb 2021
URL: https://advisories.mageia.org/MGASA-2021-0090.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2019-20326

A heap-based buffer overflow in _cairo_image_surface_create_from_jpeg() in
extensions/cairo_io/cairo-image-surface-jpeg.c in Linux Mint Pix before 2.4.5
allows attackers to cause a crash and potentially execute arbitrary code via a
crafted JPEG file (CVE-2019-20326).

References:
- https://bugs.mageia.org/show_bug.cgi?id=27908
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20326

SRPMS:
- 7/core/pix-2.4.11-1.mga7