MGASA-2021-0128 - Updated libcaca packages fix a security vulnerability

Publication date: 12 Mar 2021
URL: https://advisories.mageia.org/MGASA-2021-0128.html
Type: security
Affected Mageia releases: 7, 8
CVE: CVE-2021-3410

A buffer overflow issue in caca_resize function in libcaca/caca/canvas.c may
lead to local execution of arbitrary code in the user context (CVE-2021-3410).

References:
- https://bugs.mageia.org/show_bug.cgi?id=28556
- https://www.debian.org/lts/security/2021/dla-2584
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3410

SRPMS:
- 8/core/libcaca-0.99-0.beta19.5.1.mga8
- 7/core/libcaca-0.99-0.beta19.3.1.mga7