MGASA-2021-0131 - Updated ansible packages fix security vulnerability

Publication date: 12 Mar 2021
URL: https://advisories.mageia.org/MGASA-2021-0131.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2021-20178,
     CVE-2021-20191,
     CVE-2021-20228

User data leak in snmp_facts module (CVE-2021-20178).
Multiple collections exposed secured values (CVE-2021-20191).
In basic.py, no_log with fallback option (CVE-2021-20228).
The ansible package has been patched to fix these issues.

References:
- https://bugs.mageia.org/show_bug.cgi?id=28436
- https://access.redhat.com/errata/RHSA-2021:0664
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-20178
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-20191
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-20228

SRPMS:
- 7/core/ansible-2.7.18-1.2.mga7