MGASA-2021-0244 - Updated polkit packages fix a security vulnerability

Publication date: 08 Jun 2021
URL: https://advisories.mageia.org/MGASA-2021-0244.html
Type: security
Affected Mageia releases: 7, 8
CVE: CVE-2021-3560

A flaw was found in polkit. When a requesting process disconnects from dbus-daemon just before the call to polkit_system_bus_name_get_creds_sync starts, the process cannot get a unique uid and pid of the process and it cannot verify the privileges of the requesting process (CVE-2021-3560).

References:
- https://bugs.mageia.org/show_bug.cgi?id=29076
- https://access.redhat.com/errata/RHSA-2021:2238
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3560

SRPMS:
- 8/core/polkit-0.118-1.1.mga8
- 7/core/polkit-0.116-1.1.mga7