MGASA-2021-0259 - Updated perl-Image-ExifTool package fixes a security vulnerability

Publication date: 16 Jun 2021
URL: https://advisories.mageia.org/MGASA-2021-0259.html
Type: security
Affected Mageia releases: 7, 8
CVE: CVE-2021-22204

Improper neutralization of user data in the DjVu file format in ExifTool 
versions 7.44 and up allows arbitrary code execution when parsing the 
malicious image (CVE-2021-22204).

References:
- https://bugs.mageia.org/show_bug.cgi?id=28927
- https://www.openwall.com/lists/oss-security/2021/05/09/1
- https://lists.fedoraproject.org/archives/list/[email protected]/message/DDKDLJLBTBBR66OOPXSXCG2PQRM5KCZL/
- https://www.debian.org/security/2021/dsa-4910
- https://lists.opensuse.org/archives/list/[email protected]/thread/SLQ4XG6SNL6OL7SHPBZLVWYCAEZGZW5X/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22204

SRPMS:
- 7/core/perl-Image-ExifTool-11.300.0-1.1.mga7
- 8/core/perl-Image-ExifTool-12.0.0-1.1.mga8