MGASA-2021-0294 - Updated libgcrypt packages fix a security vulnerability

Publication date: 28 Jun 2021
URL: https://advisories.mageia.org/MGASA-2021-0294.html
Type: security
Affected Mageia releases: 7, 8
CVE: CVE-2021-33560

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption
because it lacks exponent blinding to address a side-channel attack against
mpi_powm, and the window size is not chosen appropriately (CVE-2021-33560).

References:
- https://bugs.mageia.org/show_bug.cgi?id=29162
- https://lists.suse.com/pipermail/sle-security-updates/2021-June/009053.html
- https://lists.opensuse.org/archives/list/[email protected]/thread/PPALT4SBPXXPFJVTZN5FQCXMNVH4GXCU/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-33560

SRPMS:
- 8/core/libgcrypt-1.8.7-1.1.mga8
- 7/core/libgcrypt-1.8.5-1.1.mga7