MGASA-2021-0347 - Updated kernel packages fix security vulnerabilities

Publication date: 12 Jul 2021
URL: https://advisories.mageia.org/MGASA-2021-0347.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2020-26541,
     CVE-2021-22543,
     CVE-2021-35039

This kernel update is based on upstream 5.10.48 and fixes atleast the
following security issues:

The Linux kernel through 5.8.13 does not properly enforce the Secure Boot
Forbidden Signature Database (aka dbx) protection mechanism. This affects
certs/blacklist.c and certs/system_keyring.c (CVE-2020-26541).

An issue was discovered in Linux: KVM through Improper handling of VM_IO|
VM_PFNMAP vmas in KVM can bypass RO checks and can lead to pages being
freed while still accessible by the VMM and guest. This allows users with
the ability to start and control a VM to read/write random pages of memory
and can result in local privilege escalation (CVE-2021-22543).

kernel/module.c in the Linux kernel before 5.12.14 mishandles Signature
Verification. Without CONFIG_MODULE_SIG, verification that a kernel module
is signed, for loading via init_module, does not occur for a
module.sig_enforce=1 command-line argument (CVE-2021-35039).

Other fixes in this update:
- ahci: Add support for Dell S140 and later controllers
- ALSA: hda/realtek: fix mute/micmute LEDs for HP EliteBook 830 G8
- ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 445/450/630 G8
- drm/amdgpu: fix bad address translation for sienna_cichlid
- drm/sched: Avoid data corruptions
- net: ip: avoid OOM kills with large UDP sends over loopback
- iwlwifi: Add support for ax201 in Samsung Galaxy Book Flex2 Alpha
- virtio_net: Remove BUG() to avoid machine dead

For other upstream fixes, see the referenced changelogs.

References:
- https://bugs.mageia.org/show_bug.cgi?id=29235
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.10.47
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.10.48
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-26541
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22543
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35039

SRPMS:
- 8/core/kernel-5.10.48-1.mga8
- 8/core/kmod-virtualbox-6.1.22-1.10.mga8
- 8/core/kmod-xtables-addons-3.18-1.10.mga8