MGASA-2021-0420 - Updated ansible packages fix security vulnerability

Publication date: 23 Sep 2021
URL: https://advisories.mageia.org/MGASA-2021-0420.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-3447,
     CVE-2021-3583

A flaw was found in several ansible modules, where parameters containing
credentials, such as secrets, were being logged in plain-text on managed
nodes, as well as being made visible on the controller node when run in
verbose mode.

These parameters were not protected by the no_log feature. An attacker can
take advantage of this information to steal those credentials, provided
when they have access to the log files containing them. The highest threat
from this vulnerability is to data confidentiality. This flaw affects Red
Hat Ansible Automation Platform in versions before 1.2.2 and Ansible Tower
in versions before 3.8.2 (CVE-2021-3447).

A flaw was found in Ansible, where a user's controller is vulnerable to
template injection. This issue can occur through facts used in the template
if the user is trying to put templates in multi-line YAML strings and the
facts being handled do not routinely include special template characters.
This flaw allows attackers to perform command injection, which discloses
sensitive information. The highest threat from this vulnerability is to
confidentiality and integrity (CVE-2021-3583).

References:
- https://bugs.mageia.org/show_bug.cgi?id=28832
- https://access.redhat.com/errata/RHSA-2021:1342
- https://access.redhat.com/errata/RHSA-2021:2664
- https://github.com/ansible/ansible/blob/v2.9.24/changelogs/CHANGELOG-v2.9.rst
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3447
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3583

SRPMS:
- 8/core/ansible-2.9.24-1.mga8