MGASA-2021-0501 - Updated php packages fix security vulnerability

Publication date: 31 Oct 2021
URL: https://advisories.mageia.org/MGASA-2021-0501.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-21703

Updated php packages fix security vulnerability:

In PHP versions 8.0.x below 8.0.12, when running PHP FPM SAPI with main
FPM daemon process running as root and child worker processes running as
lower-privileged users, it is possible for the child processes to access
memory shared with the main process and write to it, modifying it in a
way that would cause the root process to conduct invalid memory reads and
writes, which can be used to escalate privileges from local unprivileged
user to the root user (CVE-2021-21703).

The php packages have been updated to 8.0.12 that fixes this issue and
other bugs.

References:
- https://bugs.mageia.org/show_bug.cgi?id=29586
- https://www.php.net/ChangeLog-8.php#8.0.12
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21703

SRPMS:
- 8/core/php-8.0.12-1.mga8