MGASA-2021-0507 - Updated kernel packages fix security vulnerabilities

Publication date: 11 Nov 2021
URL: https://advisories.mageia.org/MGASA-2021-0507.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-3760,
     CVE-2021-3772,
     CVE-2021-42327,
     CVE-2021-43267,
     CVE-2021-43389

This kernel update is based on upstream 5.10.78 and fixes atleast the
following security issues:

A use-after-free vulnerability in the NFC stack can lead to a threat to
confidentiality, integrity, and system availability (CVE-2021-3760).

A flaw in the SCTP stack where a blind attacker may be able to kill an
existing SCTP association through invalid chunks if the attacker knows
the IP-addresses and port numbers being used and the attacker can send
packets with spoofed IP addresses (CVE-2021-3772).

A flaw heap buffer overflow in the Linux kernel's AMD Radeon graphics
card driver was found in the way user writes some malicious data to the
AMD GPU Display Driver Debug Filesystem (to the VGA sub-directory of the
/sys/kernel/debug/ directory). A local user could use this flaw to crash
the system or escalate their privileges on the system (CVE-2021-42327).

A flaw was discovered in the cryptographic receive code in the Linux
kernel's implementation of transparent interprocess communication. An
attacker, with the ability to send TIPC messages to the target, can
corrupt memory and escalate privileges on the target system
(CVE-2021-43267).

An issue was discovered in the Linux kernel before 5.14.15. There is an
array-index-out-of-bounds flaw in the detach_capi_ctr function in
drivers/isdn/capi/kcapi.c (CVE-2021-43389).

wireguard-tools are updated to 1.0.20210914.

For other upstream fixes, see the referenced changelogs. 

References:
- https://bugs.mageia.org/show_bug.cgi?id=29628
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.10.76
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.10.77
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.10.78
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3760
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3772
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-42327
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-43267
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-43389

SRPMS:
- 8/core/kernel-5.10.78-1.mga8
- 8/core/kmod-virtualbox-6.1.28-1.4.mga8
- 8/core/kmod-xtables-addons-3.18-1.28.mga8
- 8/core/wireguard-tools-1.0.20210914-1.mga8