MGASA-2021-0514 - Updated tinyxml packages fix security vulnerability

Publication date: 18 Nov 2021
URL: https://advisories.mageia.org/MGASA-2021-0514.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-42260

TinyXML through 2.6.2 has an infinite loop in TiXmlParsingData::Stamp in
tinyxmlparser.cpp via the TIXML_UTF_LEAD_0 case. It can be triggered by
a crafted XML message and leads to a denial of service. (CVE-2021-42260)

References:
- https://bugs.mageia.org/show_bug.cgi?id=29642
- https://lists.opensuse.org/archives/list/[email protected]/thread/2MO2YQSAKB3PM3TWSYUR2JCZND3ENJVZ/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-42260

SRPMS:
- 8/core/tinyxml-2.6.2-12.1.mga8