Mageia 2021-0558: matio security update | LinuxSecurity.com

Advisories

MGASA-2021-0558 - Updated matio packages fix security vulnerability

Publication date: 19 Dec 2021
URL: https://advisories.mageia.org/MGASA-2021-0558.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2019-20052

Updated matio packages fix security vulnerability:

A memory leak was discovered in Mat_VarCalloc in mat.c in matio 1.5.17
because SafeMulDims does not consider the rank==0 case (CVE-2019-20052).

References:
- https://bugs.mageia.org/show_bug.cgi?id=29164
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20052

SRPMS:
- 8/core/matio-1.5.21-1.mga8

Mageia 2021-0558: matio security update

Updated matio packages fix security vulnerability: A memory leak was discovered in Mat_VarCalloc in mat.c in matio 1.5.17 because SafeMulDims does not consider the rank==0 case (C...

Summary

Updated matio packages fix security vulnerability:
A memory leak was discovered in Mat_VarCalloc in mat.c in matio 1.5.17 because SafeMulDims does not consider the rank==0 case (CVE-2019-20052).

References

- https://bugs.mageia.org/show_bug.cgi?id=29164

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20052

Resolution

MGASA-2021-0558 - Updated matio packages fix security vulnerability

SRPMS

- 8/core/matio-1.5.21-1.mga8

Severity
Publication date: 19 Dec 2021
URL: https://advisories.mageia.org/MGASA-2021-0558.html
Type: security
CVE: CVE-2019-20052

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.