MGASA-2021-0562 - Updated hiredis packages fix security vulnerability

Publication date: 19 Dec 2021
URL: https://advisories.mageia.org/MGASA-2021-0562.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-32765

Updated hiredis packages fix security vulnerability:

It was discovered that there was an integer-overflow vulnerability in
hiredis, a C client library for communicating with Redis databases.
This occurred within the handling and parsing of 'multi-bulk' replies
(CVE-2021-32765).

References:
- https://bugs.mageia.org/show_bug.cgi?id=29549
- https://github.com/redis/hiredis/security/advisories/GHSA-hfm9-39pp-55p2
- https://www.debian.org/lts/security/2021/dla-2783
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-32765

SRPMS:
- 8/core/hiredis-0.13.3-6.1.mga8