MGASA-2021-0576 - Updated apache-mod_security packages fix security vulnerability

Publication date: 21 Dec 2021
URL: https://advisories.mageia.org/MGASA-2021-0576.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-42717

Updated apache-mod_security packages fix security vulnerability:

ModSecurity mishandles excessively nested JSON objects. Crafted JSON
objects with nesting tens-of-thousands deep could result in the web
server being unable to service legitimate requests. Even a moderately
large (e.g., 300KB) HTTP request can occupy one of the limited NGINX
worker processes for minutes and consume almost all of the available
CPU on the machine (CVE-2021-42717).

References:
- https://bugs.mageia.org/show_bug.cgi?id=29787
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-42717

SRPMS:
- 8/core/apache-mod_security-2.9.5-1.mga8