MGASA-2022-0015 - Updated vim packages fix security vulnerability

Publication date: 15 Jan 2022
URL: https://advisories.mageia.org/MGASA-2022-0015.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-4136,
     CVE-2021-4166,
     CVE-2021-4173,
     CVE-2021-4187

CWE-122 Heap-based Buffer Overflow (CVE-2021-4136)
CWE-125 Out-of-bounds Read (CVE-2021-4166)
CWE-416 Use After Free (CVE-2021-4173)
CWE-416 Use After Free (CVE-2021-4187)

References:
- https://bugs.mageia.org/show_bug.cgi?id=29856
- https://lists.fedoraproject.org/archives/list/[email protected]/thread/2EY2VFBU3YGGWI5BW4XKT3F37MYGEQUD/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4136
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4166
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4173
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4187

SRPMS:
- 8/core/vim-8.2.4006-1.mga8