MGASA-2022-0030 - Updated libreswan packages fix security vulnerability

Publication date: 25 Jan 2022
URL: https://advisories.mageia.org/MGASA-2022-0030.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-23094

Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of
service (NULL pointer dereference and daemon crash) via a crafted IKEv1
packet because pluto/ikev1.c wrongly expects that a state object exists.
(CVE-2022-23094)

References:
- https://bugs.mageia.org/show_bug.cgi?id=29900
- https://nvd.nist.gov/vuln/detail/CVE-2022-23094
- https://libreswan.org/security/CVE-2022-23094/CVE-2022-23094.txt
- https://www.debian.org/security/2022/dsa-5048
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-23094

SRPMS:
- 8/core/libreswan-4.6-4.mga8