MGASA-2022-0082 - Updated htmldoc packages fix security vulnerability

Publication date: 22 Feb 2022
URL: https://advisories.mageia.org/MGASA-2022-0082.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-0534

A vulnerability was found in htmldoc version 1.9.15 where the stack
out-of-bounds read takes place in gif_get_code() and occurs when opening a
malicious GIF file, which can result in a crash (segmentation fault).
(CVE-2022-0534)

References:
- https://bugs.mageia.org/show_bug.cgi?id=30077
- https://lists.opensuse.org/archives/list/[email protected]/thread/3NVMNRQWPBYKG2XDRDYA4JPEMALW53MA/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0534

SRPMS:
- 8/core/htmldoc-1.9.15-1.mga8