Mageia 2022-0297: freetype2 security update | LinuxSecurity.com

Advisories

MGASA-2022-0297 - Updated freetype2 packages fix security vulnerability

Publication date: 25 Aug 2022
URL: https://advisories.mageia.org/MGASA-2022-0297.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-31782

ftbench.c in FreeType Demo Programs through 2.12.1 has a heap-based buffer
overflow. (CVE-2022-31782)

References:
- https://bugs.mageia.org/show_bug.cgi?id=30659
- https://ubuntu.com/security/notices/USN-5528-1
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-31782

SRPMS:
- 8/core/freetype2-2.10.4-2.2.mga8
- 8/tainted/freetype2-2.10.4-2.2.mga8.tainted

Mageia 2022-0297: freetype2 security update

ftbench.c in FreeType Demo Programs through 2.12.1 has a heap-based buffer overflow

Summary

ftbench.c in FreeType Demo Programs through 2.12.1 has a heap-based buffer overflow. (CVE-2022-31782)

References

- https://bugs.mageia.org/show_bug.cgi?id=30659

- https://ubuntu.com/security/notices/USN-5528-1

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-31782

Resolution

MGASA-2022-0297 - Updated freetype2 packages fix security vulnerability

SRPMS

- 8/core/freetype2-2.10.4-2.2.mga8

- 8/tainted/freetype2-2.10.4-2.2.mga8.tainted

Severity
Publication date: 25 Aug 2022
URL: https://advisories.mageia.org/MGASA-2022-0297.html
Type: security
CVE: CVE-2022-31782

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.