Discover Government News


MGASA-2024-0040 - Updated vim packages fix a security vulnerability

Publication date: 17 Feb 2024
URL: https://advisories.mageia.org/MGASA-2024-0040.html
Type: security
Affected Mageia releases: 9
CVE: CVE-2024-22667

The updated packages fix a security vulnerability:
Vim before 9.0.2142 has a stack-based buffer overflow because
did_set_langmap in map.c calls sprintf to write to the error buffer that
is passed down to the option callback functions. (CVE-2024-22667)

References:
- https://bugs.mageia.org/show_bug.cgi?id=32850
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UIQLVUSYHDN3644K6EFDI7PRZOTIKXM3/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-22667

SRPMS:
- 9/core/vim-9.1.111-1.mga9

Mageia 2024-0040: vim security update

The updated packages fix a security vulnerability: Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c calls sprintf to write to the error buffer...

Summary

The updated packages fix a security vulnerability: Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c calls sprintf to write to the error buffer that is passed down to the option callback functions. (CVE-2024-22667)

References

- https://bugs.mageia.org/show_bug.cgi?id=32850

- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UIQLVUSYHDN3644K6EFDI7PRZOTIKXM3/

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2024-22667

Resolution

MGASA-2024-0040 - Updated vim packages fix a security vulnerability

SRPMS

- 9/core/vim-9.1.111-1.mga9

Severity
Publication date: 17 Feb 2024
URL: https://advisories.mageia.org/MGASA-2024-0040.html
Type: security
CVE: CVE-2024-22667

Related News