Discover Government News

   openSUSE Security Update: rpm (CVE-2011-3378)
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2011:1203-1
Rating:             important
References:         #720824 
Cross-References:   CVE-2011-3378
Affected Products:
                    openSUSE 11.4
                    openSUSE 11.3
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   Specially crafted rpm packages can cause memory corruption
   in rpm when verifying signatures (CVE-2011-3378).


Patch Instructions:

   To install this openSUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - openSUSE 11.4:

      zypper in -t patch rpm-5255

   - openSUSE 11.3:

      zypper in -t patch rpm-5255

   To bring your system up-to-date, use "zypper patch".


Package List:

   - openSUSE 11.4 (i586 x86_64):

      rpm-4.8.0-28.29.1
      rpm-devel-4.8.0-28.29.1

   - openSUSE 11.4 (x86_64):

      rpm-32bit-4.8.0-28.29.1

   - openSUSE 11.3 (i586 x86_64):

      rpm-4.8.0-5.3.1
      rpm-devel-4.8.0-5.3.1

   - openSUSE 11.3 (x86_64):

      rpm-32bit-4.8.0-5.3.1


References:

   https://www.suse.com/security/cve/CVE-2011-3378.html
   https://bugzilla.novell.com/720824

-- 

openSUSE: 2011:1203-1: important: rpm (CVE-2011-3378)

November 2, 2011
An update that fixes one vulnerability is now available.

Description

Specially crafted rpm packages can cause memory corruption in rpm when verifying signatures (CVE-2011-3378).

 

Patch

Patch Instructions: To install this openSUSE Security Update use YaST online_update. Alternatively you can run the command listed for your product: - openSUSE 11.4: zypper in -t patch rpm-5255 - openSUSE 11.3: zypper in -t patch rpm-5255 To bring your system up-to-date, use "zypper patch".


Package List

- openSUSE 11.4 (i586 x86_64): rpm-4.8.0-28.29.1 rpm-devel-4.8.0-28.29.1 - openSUSE 11.4 (x86_64): rpm-32bit-4.8.0-28.29.1 - openSUSE 11.3 (i586 x86_64): rpm-4.8.0-5.3.1 rpm-devel-4.8.0-5.3.1 - openSUSE 11.3 (x86_64): rpm-32bit-4.8.0-5.3.1


References

https://www.suse.com/security/cve/CVE-2011-3378.html https://bugzilla.novell.com/720824--


Severity
Announcement ID: openSUSE-SU-2011:1203-1
Rating: important
Affected Products: openSUSE 11.4 openSUSE 11.3

Related News