Discover Government News

   openSUSE Security Update: libxml2: fixed buffer overflow during decoding entities
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2013:0178-1
Rating:             important
References:         #793334 
Cross-References:   CVE-2012-5134
Affected Products:
                    openSUSE 11.4/standard/i586/patchinfo.30
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   A Heap-based buffer underflow in the
   xmlParseAttValueComplex function in parser.c in libxml2
   allowed remote attackers to cause a denial of service or
   possibly execute arbitrary code via crafted entities in an
   XML document.


Patch Instructions:

   To install this openSUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - openSUSE 11.4/standard/i586/patchinfo.30:

      zypper in -t patch 2012-19

   To bring your system up-to-date, use "zypper patch".


Package List:

   - openSUSE 11.4/standard/i586/patchinfo.30 (i586 x86_64):

      libxml2-2.7.8-37.1
      libxml2-debuginfo-2.7.8-37.1
      libxml2-debugsource-2.7.8-37.1
      libxml2-devel-2.7.8-37.1

   - openSUSE 11.4/standard/i586/patchinfo.30 (x86_64):

      libxml2-32bit-2.7.8-37.1
      libxml2-debuginfo-32bit-2.7.8-37.1
      libxml2-devel-32bit-2.7.8-37.1

   - openSUSE 11.4/standard/i586/patchinfo.30 (noarch):

      libxml2-doc-2.7.8-37.1

   - openSUSE 11.4/standard/i586/patchinfo.30 (ia64):

      libxml2-debuginfo-x86-2.7.8-37.1
      libxml2-x86-2.7.8-37.1


References:

   https://www.suse.com/security/cve/CVE-2012-5134.html
   https://bugzilla.novell.com/793334

-- 

openSUSE: 2013:0178-1: important: libxml2

January 23, 2013
An update that fixes one vulnerability is now available.

Description

A Heap-based buffer underflow in the xmlParseAttValueComplex function in parser.c in libxml2 allowed remote attackers to cause a denial of service or possibly execute arbitrary code via crafted entities in an XML document.

 

Patch

Patch Instructions: To install this openSUSE Security Update use YaST online_update. Alternatively you can run the command listed for your product: - openSUSE 11.4/standard/i586/patchinfo.30: zypper in -t patch 2012-19 To bring your system up-to-date, use "zypper patch".


Package List

- openSUSE 11.4/standard/i586/patchinfo.30 (i586 x86_64): libxml2-2.7.8-37.1 libxml2-debuginfo-2.7.8-37.1 libxml2-debugsource-2.7.8-37.1 libxml2-devel-2.7.8-37.1 - openSUSE 11.4/standard/i586/patchinfo.30 (x86_64): libxml2-32bit-2.7.8-37.1 libxml2-debuginfo-32bit-2.7.8-37.1 libxml2-devel-32bit-2.7.8-37.1 - openSUSE 11.4/standard/i586/patchinfo.30 (noarch): libxml2-doc-2.7.8-37.1 - openSUSE 11.4/standard/i586/patchinfo.30 (ia64): libxml2-debuginfo-x86-2.7.8-37.1 libxml2-x86-2.7.8-37.1


References

https://www.suse.com/security/cve/CVE-2012-5134.html https://bugzilla.novell.com/793334--


Severity
Announcement ID: openSUSE-SU-2013:0178-1
Rating: important
Affected Products: openSUSE 11.4/standard/i586/patchinfo.30

Related News