openSUSE Security Update: Security update for opencv
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2018:1271-1
Rating:             important
References:         #1033150 #1033152 
Cross-References:   CVE-2016-1516 CVE-2016-1517
Affected Products:
                    SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for opencv fixes the following issues:

   - CVE-2016-1517: Fixed a denial of service (segfault) via vectors     involving corrupt chunks (boo#1033150)
   - CVE-2016-1516: Fixed a double free issue that allows attackers to
     execute arbitrary code (boo#1033152).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Package Hub for SUSE Linux Enterprise 12:

      zypper in -t patch openSUSE-2018-455=1



Package List:

   - SUSE Package Hub for SUSE Linux Enterprise 12 (x86_64):

      libopencv-qt56_3-3.1.0-5.1
      libopencv-qt56_3-debuginfo-3.1.0-5.1
      libopencv3_1-3.1.0-5.1
      opencv-3.1.0-5.1
      opencv-devel-3.1.0-5.1
      opencv-doc-3.1.0-5.1
      opencv-qt5-3.1.0-5.1
      opencv-qt5-debuginfo-3.1.0-5.1
      opencv-qt5-debugsource-3.1.0-5.1
      opencv-qt5-devel-3.1.0-5.1
      opencv-qt5-doc-3.1.0-5.1
      python-opencv-3.1.0-5.1
      python-opencv-qt5-3.1.0-5.1
      python-opencv-qt5-debuginfo-3.1.0-5.1
      python3-opencv-3.1.0-5.1
      python3-opencv-qt5-3.1.0-5.1
      python3-opencv-qt5-debuginfo-3.1.0-5.1


References:

   https://www.suse.com/security/cve/CVE-2016-1516.html
   https://www.suse.com/security/cve/CVE-2016-1517.html
   https://bugzilla.suse.com/1033150
   https://bugzilla.suse.com/1033152

-- 

openSUSE: 2018:1271-1: important: opencv

May 12, 2018
An update that fixes two vulnerabilities is now available.

Description

This update for opencv fixes the following issues: - CVE-2016-1517: Fixed a denial of service (segfault) via vectors involving corrupt chunks (boo#1033150) - CVE-2016-1516: Fixed a double free issue that allows attackers to execute arbitrary code (boo#1033152).

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Package Hub for SUSE Linux Enterprise 12: zypper in -t patch openSUSE-2018-455=1


Package List

- SUSE Package Hub for SUSE Linux Enterprise 12 (x86_64): libopencv-qt56_3-3.1.0-5.1 libopencv-qt56_3-debuginfo-3.1.0-5.1 libopencv3_1-3.1.0-5.1 opencv-3.1.0-5.1 opencv-devel-3.1.0-5.1 opencv-doc-3.1.0-5.1 opencv-qt5-3.1.0-5.1 opencv-qt5-debuginfo-3.1.0-5.1 opencv-qt5-debugsource-3.1.0-5.1 opencv-qt5-devel-3.1.0-5.1 opencv-qt5-doc-3.1.0-5.1 python-opencv-3.1.0-5.1 python-opencv-qt5-3.1.0-5.1 python-opencv-qt5-debuginfo-3.1.0-5.1 python3-opencv-3.1.0-5.1 python3-opencv-qt5-3.1.0-5.1 python3-opencv-qt5-debuginfo-3.1.0-5.1


References

https://www.suse.com/security/cve/CVE-2016-1516.html https://www.suse.com/security/cve/CVE-2016-1517.html https://bugzilla.suse.com/1033150 https://bugzilla.suse.com/1033152--


Severity
Announcement ID: openSUSE-SU-2018:1271-1
Rating: important
Affected Products: SUSE Package Hub for SUSE Linux Enterprise 12

Related News