Linux Security
    Linux Security
    Linux Security

    openSUSE: 2020:1416-1: moderate: openldap2

    Date
    192
    Posted By
    An update that fixes one vulnerability is now available.
       openSUSE Security Update: Security update for openldap2
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2020:1416-1
    Rating:             moderate
    References:         #1174154 
    Cross-References:   CVE-2020-15719
    Affected Products:
                        openSUSE Leap 15.1
    ______________________________________________________________________________
    
       An update that fixes one vulnerability is now available.
    
    Description:
    
       This update for openldap2 fixes the following issues:
    
       - bsc#1174154 - CVE-2020-15719 - This resolves an issue with x509 SAN's
         falling back to CN validation in violation of rfc6125.
    
       This update was imported from the SUSE:SLE-15:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2020-1416=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (i586 x86_64):
    
          libldap-2_4-2-2.4.46-lp151.10.15.1
          libldap-2_4-2-debuginfo-2.4.46-lp151.10.15.1
          openldap2-2.4.46-lp151.10.15.1
          openldap2-back-meta-2.4.46-lp151.10.15.1
          openldap2-back-meta-debuginfo-2.4.46-lp151.10.15.1
          openldap2-back-perl-2.4.46-lp151.10.15.1
          openldap2-back-perl-debuginfo-2.4.46-lp151.10.15.1
          openldap2-back-sock-2.4.46-lp151.10.15.1
          openldap2-back-sock-debuginfo-2.4.46-lp151.10.15.1
          openldap2-back-sql-2.4.46-lp151.10.15.1
          openldap2-back-sql-debuginfo-2.4.46-lp151.10.15.1
          openldap2-client-2.4.46-lp151.10.15.1
          openldap2-client-debuginfo-2.4.46-lp151.10.15.1
          openldap2-contrib-2.4.46-lp151.10.15.1
          openldap2-contrib-debuginfo-2.4.46-lp151.10.15.1
          openldap2-debuginfo-2.4.46-lp151.10.15.1
          openldap2-debugsource-2.4.46-lp151.10.15.1
          openldap2-devel-2.4.46-lp151.10.15.1
          openldap2-devel-static-2.4.46-lp151.10.15.1
          openldap2-ppolicy-check-password-1.2-lp151.10.15.1
          openldap2-ppolicy-check-password-debuginfo-1.2-lp151.10.15.1
    
       - openSUSE Leap 15.1 (noarch):
    
          libldap-data-2.4.46-lp151.10.15.1
          openldap2-doc-2.4.46-lp151.10.15.1
    
       - openSUSE Leap 15.1 (x86_64):
    
          libldap-2_4-2-32bit-2.4.46-lp151.10.15.1
          libldap-2_4-2-32bit-debuginfo-2.4.46-lp151.10.15.1
          openldap2-devel-32bit-2.4.46-lp151.10.15.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2020-15719.html
       https://bugzilla.suse.com/1174154
    
    -- 
    

    LinuxSecurity Poll

    How are you contributing to Open Source?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 4 answer(s).
    /main-polls/37-how-are-you-contributing-to-open-source?task=poll.vote&format=json
    37
    radio
    [{"id":"127","title":"I'm involved with the development of an open-source project(s).","votes":"1","type":"x","order":"1","pct":100,"resources":[]},{"id":"128","title":"I've reported vulnerabilities I've discovered in open-source code.","votes":"0","type":"x","order":"2","pct":0,"resources":[]},{"id":"129","title":"I've provided developers with feedback on their projects.","votes":"0","type":"x","order":"3","pct":0,"resources":[]},{"id":"130","title":"I've helped another community member get started contributing to Open Source.","votes":"0","type":"x","order":"4","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.