openSUSE Security Update: Security update for pdns-recursor
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:1687-1
Rating:             important
References:         #1173302 #1177383 
Cross-References:   CVE-2020-14196 CVE-2020-25829
Affected Products:
                    openSUSE Leap 15.2
                    openSUSE Leap 15.1
                    openSUSE Backports SLE-15-SP2
                    openSUSE Backports SLE-15-SP1
                    SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for pdns-recursor fixes the following issues:

   -pdns-recursorwas updated to 4.1.1 and 4.3.5:
      - CVE-2020-25829: Fixed a cache pollution related to DNSSEC validation
        (boo#1177383)
      - CVE-2020-14196: Fixed an access restriction bypass with API key and
        password authentication (boo#1173302).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2020-1687=1

   - openSUSE Leap 15.1:

      zypper in -t patch openSUSE-2020-1687=1

   - openSUSE Backports SLE-15-SP2:

      zypper in -t patch openSUSE-2020-1687=1

   - openSUSE Backports SLE-15-SP1:

      zypper in -t patch openSUSE-2020-1687=1

   - SUSE Package Hub for SUSE Linux Enterprise 12:

      zypper in -t patch openSUSE-2020-1687=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      pdns-recursor-4.3.5-lp152.2.6.1
      pdns-recursor-debuginfo-4.3.5-lp152.2.6.1
      pdns-recursor-debugsource-4.3.5-lp152.2.6.1

   - openSUSE Leap 15.1 (x86_64):

      pdns-recursor-4.1.12-lp151.3.9.1
      pdns-recursor-debuginfo-4.1.12-lp151.3.9.1
      pdns-recursor-debugsource-4.1.12-lp151.3.9.1

   - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64):

      pdns-recursor-4.3.5-bp152.2.12.1
      pdns-recursor-debuginfo-4.3.5-bp152.2.12.1
      pdns-recursor-debugsource-4.3.5-bp152.2.12.1

   - openSUSE Backports SLE-15-SP1 (aarch64 ppc64le s390x x86_64):

      pdns-recursor-4.1.12-bp151.4.9.1
      pdns-recursor-debuginfo-4.1.12-bp151.4.9.1
      pdns-recursor-debugsource-4.1.12-bp151.4.9.1

   - SUSE Package Hub for SUSE Linux Enterprise 12 (aarch64 ppc64le s390x x86_64):

      pdns-recursor-4.1.18-25.1


References:

   https://www.suse.com/security/cve/CVE-2020-14196.html
   https://www.suse.com/security/cve/CVE-2020-25829.html
   https://bugzilla.suse.com/1173302
   https://bugzilla.suse.com/1177383

-- 

openSUSE: 2020:1687-1: important: pdns-recursor

October 17, 2020
An update that fixes two vulnerabilities is now available.

Description

This update for pdns-recursor fixes the following issues: -pdns-recursorwas updated to 4.1.1 and 4.3.5: - CVE-2020-25829: Fixed a cache pollution related to DNSSEC validation (boo#1177383) - CVE-2020-14196: Fixed an access restriction bypass with API key and password authentication (boo#1173302).

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2020-1687=1 - openSUSE Leap 15.1: zypper in -t patch openSUSE-2020-1687=1 - openSUSE Backports SLE-15-SP2: zypper in -t patch openSUSE-2020-1687=1 - openSUSE Backports SLE-15-SP1: zypper in -t patch openSUSE-2020-1687=1 - SUSE Package Hub for SUSE Linux Enterprise 12: zypper in -t patch openSUSE-2020-1687=1


Package List

- openSUSE Leap 15.2 (x86_64): pdns-recursor-4.3.5-lp152.2.6.1 pdns-recursor-debuginfo-4.3.5-lp152.2.6.1 pdns-recursor-debugsource-4.3.5-lp152.2.6.1 - openSUSE Leap 15.1 (x86_64): pdns-recursor-4.1.12-lp151.3.9.1 pdns-recursor-debuginfo-4.1.12-lp151.3.9.1 pdns-recursor-debugsource-4.1.12-lp151.3.9.1 - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64): pdns-recursor-4.3.5-bp152.2.12.1 pdns-recursor-debuginfo-4.3.5-bp152.2.12.1 pdns-recursor-debugsource-4.3.5-bp152.2.12.1 - openSUSE Backports SLE-15-SP1 (aarch64 ppc64le s390x x86_64): pdns-recursor-4.1.12-bp151.4.9.1 pdns-recursor-debuginfo-4.1.12-bp151.4.9.1 pdns-recursor-debugsource-4.1.12-bp151.4.9.1 - SUSE Package Hub for SUSE Linux Enterprise 12 (aarch64 ppc64le s390x x86_64): pdns-recursor-4.1.18-25.1


References

https://www.suse.com/security/cve/CVE-2020-14196.html https://www.suse.com/security/cve/CVE-2020-25829.html https://bugzilla.suse.com/1173302 https://bugzilla.suse.com/1177383--


Severity
Announcement ID: openSUSE-SU-2020:1687-1
Rating: important
Affected Products: openSUSE Leap 15.2 openSUSE Leap 15.1 openSUSE Backports SLE-15-SP2 openSUSE Backports SLE-15-SP1 SUSE Package Hub for SUSE Linux Enterprise 12

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo