Linux Security
    Linux Security
    Linux Security

    openSUSE: 2020:1743-1: moderate: gnutls

    Date
    95
    Posted By
    An update that solves one vulnerability and has two fixes is now available.
       openSUSE Security Update: Security update for gnutls
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2020:1743-1
    Rating:             moderate
    References:         #1176086 #1176181 #1176671 
    Cross-References:   CVE-2020-24659
    Affected Products:
                        openSUSE Leap 15.2
    ______________________________________________________________________________
    
       An update that solves one vulnerability and has two fixes
       is now available.
    
    Description:
    
       This update for gnutls fixes the following issues:
    
       - Fix heap buffer overflow in handshake with no_renegotiation alert sent
         (CVE-2020-24659 bsc#1176181)
       - FIPS: Implement (EC)DH requirements from SP800-56Arev3 (bsc#1176086)
       - FIPS: Use 2048 bit prime in DH selftest (bsc#1176086)
       - FIPS: Add TLS KDF selftest (bsc#1176671)
    
       This update was imported from the SUSE:SLE-15:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.2:
    
          zypper in -t patch openSUSE-2020-1743=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.2 (i586 x86_64):
    
          gnutls-3.6.7-lp152.9.3.2
          gnutls-debuginfo-3.6.7-lp152.9.3.2
          gnutls-debugsource-3.6.7-lp152.9.3.2
          gnutls-guile-3.6.7-lp152.9.3.2
          gnutls-guile-debuginfo-3.6.7-lp152.9.3.2
          libgnutls-dane-devel-3.6.7-lp152.9.3.2
          libgnutls-dane0-3.6.7-lp152.9.3.2
          libgnutls-dane0-debuginfo-3.6.7-lp152.9.3.2
          libgnutls-devel-3.6.7-lp152.9.3.2
          libgnutls30-3.6.7-lp152.9.3.2
          libgnutls30-debuginfo-3.6.7-lp152.9.3.2
          libgnutls30-hmac-3.6.7-lp152.9.3.2
          libgnutlsxx-devel-3.6.7-lp152.9.3.2
          libgnutlsxx28-3.6.7-lp152.9.3.2
          libgnutlsxx28-debuginfo-3.6.7-lp152.9.3.2
    
       - openSUSE Leap 15.2 (x86_64):
    
          libgnutls-devel-32bit-3.6.7-lp152.9.3.2
          libgnutls30-32bit-3.6.7-lp152.9.3.2
          libgnutls30-32bit-debuginfo-3.6.7-lp152.9.3.2
          libgnutls30-hmac-32bit-3.6.7-lp152.9.3.2
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2020-24659.html
       https://bugzilla.suse.com/1176086
       https://bugzilla.suse.com/1176181
       https://bugzilla.suse.com/1176671
    
    -- 
    

    LinuxSecurity Poll

    I agree with Linus Torvalds - Apple's new M1-powered laptops should run on Linux.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/45-i-agree-with-linus-torvalds-apple-s-new-m1-powered-laptops-should-run-on-linux?task=poll.vote&format=json
    45
    radio
    [{"id":"158","title":"True","votes":"8","type":"x","order":"1","pct":100,"resources":[]},{"id":"159","title":"False","votes":"0","type":"x","order":"2","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.