Discover Government News

   openSUSE Security Update: Security update for LibVNCServer
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:2025-1
Rating:             important
References:         #1178682 
Cross-References:   CVE-2020-25708
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for LibVNCServer fixes the following issues:

   - CVE-2020-25708 [bsc#1178682], libvncserver/rfbserver.c has a divide by
     zero which could result in DoS

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2020-2025=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      LibVNCServer-debugsource-0.9.10-lp152.9.8.1
      LibVNCServer-devel-0.9.10-lp152.9.8.1
      libvncclient0-0.9.10-lp152.9.8.1
      libvncclient0-debuginfo-0.9.10-lp152.9.8.1
      libvncserver0-0.9.10-lp152.9.8.1
      libvncserver0-debuginfo-0.9.10-lp152.9.8.1


References:

   https://www.suse.com/security/cve/CVE-2020-25708.html
   https://bugzilla.suse.com/1178682
_______________________________________________
openSUSE Security Announce mailing list -- security-announce@lists.opensuse.org
To unsubscribe, email security-announce-leave@lists.opensuse.org
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/

openSUSE: 2020:2025-1 important: LibVNCServer

November 26, 2020
An update that fixes one vulnerability is now available.

Description

This update for LibVNCServer fixes the following issues: - CVE-2020-25708 [bsc#1178682], libvncserver/rfbserver.c has a divide by zero which could result in DoS This update was imported from the SUSE:SLE-15:Update update project.

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2020-2025=1


Package List

- openSUSE Leap 15.2 (i586 x86_64): LibVNCServer-debugsource-0.9.10-lp152.9.8.1 LibVNCServer-devel-0.9.10-lp152.9.8.1 libvncclient0-0.9.10-lp152.9.8.1 libvncclient0-debuginfo-0.9.10-lp152.9.8.1 libvncserver0-0.9.10-lp152.9.8.1 libvncserver0-debuginfo-0.9.10-lp152.9.8.1


References

https://www.suse.com/security/cve/CVE-2020-25708.html https://bugzilla.suse.com/1178682 openSUSE Security Announce mailing list -- security-announce@lists.opensuse.org To unsubscribe, email security-announce-leave@lists.opensuse.org List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette List Archives: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/


Severity
Announcement ID: openSUSE-SU-2020:2025-1
Rating: important
Affected Products: openSUSE Leap 15.2

Related News