Discover Government News

   openSUSE Security Update: Security update for slurm
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:2033-1
Rating:             important
References:         #1178890 #1178891 
Cross-References:   CVE-2020-27745 CVE-2020-27746
Affected Products:
                    openSUSE Leap 15.1
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for slurm fixes the following issues:

   - CVE-2020-27745: PMIx - fix potential buffer overflows from use of
     unpackmem() (bsc#1178890).
   - CVE-2020-27746: X11 forwarding - fix potential leak of the magic cookie
     when sent as an argument to the xauth command (bsc#1178891).

   This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.1:

      zypper in -t patch openSUSE-2020-2033=1



Package List:

   - openSUSE Leap 15.1 (x86_64):

      libpmi0-18.08.9-lp151.2.14.1
      libpmi0-debuginfo-18.08.9-lp151.2.14.1
      libslurm33-18.08.9-lp151.2.14.1
      libslurm33-debuginfo-18.08.9-lp151.2.14.1
      perl-slurm-18.08.9-lp151.2.14.1
      perl-slurm-debuginfo-18.08.9-lp151.2.14.1
      slurm-18.08.9-lp151.2.14.1
      slurm-auth-none-18.08.9-lp151.2.14.1
      slurm-auth-none-debuginfo-18.08.9-lp151.2.14.1
      slurm-config-18.08.9-lp151.2.14.1
      slurm-config-man-18.08.9-lp151.2.14.1
      slurm-cray-18.08.9-lp151.2.14.1
      slurm-cray-debuginfo-18.08.9-lp151.2.14.1
      slurm-debuginfo-18.08.9-lp151.2.14.1
      slurm-debugsource-18.08.9-lp151.2.14.1
      slurm-devel-18.08.9-lp151.2.14.1
      slurm-doc-18.08.9-lp151.2.14.1
      slurm-hdf5-18.08.9-lp151.2.14.1
      slurm-hdf5-debuginfo-18.08.9-lp151.2.14.1
      slurm-lua-18.08.9-lp151.2.14.1
      slurm-lua-debuginfo-18.08.9-lp151.2.14.1
      slurm-munge-18.08.9-lp151.2.14.1
      slurm-munge-debuginfo-18.08.9-lp151.2.14.1
      slurm-node-18.08.9-lp151.2.14.1
      slurm-node-debuginfo-18.08.9-lp151.2.14.1
      slurm-openlava-18.08.9-lp151.2.14.1
      slurm-pam_slurm-18.08.9-lp151.2.14.1
      slurm-pam_slurm-debuginfo-18.08.9-lp151.2.14.1
      slurm-plugins-18.08.9-lp151.2.14.1
      slurm-plugins-debuginfo-18.08.9-lp151.2.14.1
      slurm-seff-18.08.9-lp151.2.14.1
      slurm-sjstat-18.08.9-lp151.2.14.1
      slurm-slurmdbd-18.08.9-lp151.2.14.1
      slurm-slurmdbd-debuginfo-18.08.9-lp151.2.14.1
      slurm-sql-18.08.9-lp151.2.14.1
      slurm-sql-debuginfo-18.08.9-lp151.2.14.1
      slurm-sview-18.08.9-lp151.2.14.1
      slurm-sview-debuginfo-18.08.9-lp151.2.14.1
      slurm-torque-18.08.9-lp151.2.14.1
      slurm-torque-debuginfo-18.08.9-lp151.2.14.1
      slurm-webdoc-18.08.9-lp151.2.14.1


References:

   https://www.suse.com/security/cve/CVE-2020-27745.html
   https://www.suse.com/security/cve/CVE-2020-27746.html
   https://bugzilla.suse.com/1178890
   https://bugzilla.suse.com/1178891
_______________________________________________
openSUSE Security Announce mailing list -- security-announce@lists.opensuse.org
To unsubscribe, email security-announce-leave@lists.opensuse.org
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/

openSUSE: 2020:2033-1 important: slurm

November 26, 2020
An update that fixes two vulnerabilities is now available.

Description

This update for slurm fixes the following issues: - CVE-2020-27745: PMIx - fix potential buffer overflows from use of unpackmem() (bsc#1178890). - CVE-2020-27746: X11 forwarding - fix potential leak of the magic cookie when sent as an argument to the xauth command (bsc#1178891). This update was imported from the SUSE:SLE-15-SP1:Update update project.

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.1: zypper in -t patch openSUSE-2020-2033=1


Package List

- openSUSE Leap 15.1 (x86_64): libpmi0-18.08.9-lp151.2.14.1 libpmi0-debuginfo-18.08.9-lp151.2.14.1 libslurm33-18.08.9-lp151.2.14.1 libslurm33-debuginfo-18.08.9-lp151.2.14.1 perl-slurm-18.08.9-lp151.2.14.1 perl-slurm-debuginfo-18.08.9-lp151.2.14.1 slurm-18.08.9-lp151.2.14.1 slurm-auth-none-18.08.9-lp151.2.14.1 slurm-auth-none-debuginfo-18.08.9-lp151.2.14.1 slurm-config-18.08.9-lp151.2.14.1 slurm-config-man-18.08.9-lp151.2.14.1 slurm-cray-18.08.9-lp151.2.14.1 slurm-cray-debuginfo-18.08.9-lp151.2.14.1 slurm-debuginfo-18.08.9-lp151.2.14.1 slurm-debugsource-18.08.9-lp151.2.14.1 slurm-devel-18.08.9-lp151.2.14.1 slurm-doc-18.08.9-lp151.2.14.1 slurm-hdf5-18.08.9-lp151.2.14.1 slurm-hdf5-debuginfo-18.08.9-lp151.2.14.1 slurm-lua-18.08.9-lp151.2.14.1 slurm-lua-debuginfo-18.08.9-lp151.2.14.1 slurm-munge-18.08.9-lp151.2.14.1 slurm-munge-debuginfo-18.08.9-lp151.2.14.1 slurm-node-18.08.9-lp151.2.14.1 slurm-node-debuginfo-18.08.9-lp151.2.14.1 slurm-openlava-18.08.9-lp151.2.14.1 slurm-pam_slurm-18.08.9-lp151.2.14.1 slurm-pam_slurm-debuginfo-18.08.9-lp151.2.14.1 slurm-plugins-18.08.9-lp151.2.14.1 slurm-plugins-debuginfo-18.08.9-lp151.2.14.1 slurm-seff-18.08.9-lp151.2.14.1 slurm-sjstat-18.08.9-lp151.2.14.1 slurm-slurmdbd-18.08.9-lp151.2.14.1 slurm-slurmdbd-debuginfo-18.08.9-lp151.2.14.1 slurm-sql-18.08.9-lp151.2.14.1 slurm-sql-debuginfo-18.08.9-lp151.2.14.1 slurm-sview-18.08.9-lp151.2.14.1 slurm-sview-debuginfo-18.08.9-lp151.2.14.1 slurm-torque-18.08.9-lp151.2.14.1 slurm-torque-debuginfo-18.08.9-lp151.2.14.1 slurm-webdoc-18.08.9-lp151.2.14.1


References

https://www.suse.com/security/cve/CVE-2020-27745.html https://www.suse.com/security/cve/CVE-2020-27746.html https://bugzilla.suse.com/1178890 https://bugzilla.suse.com/1178891 openSUSE Security Announce mailing list -- security-announce@lists.opensuse.org To unsubscribe, email security-announce-leave@lists.opensuse.org List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette List Archives: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/


Severity
Announcement ID: openSUSE-SU-2020:2033-1
Rating: important
Affected Products: openSUSE Leap 15.1

Related News